assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

Epoccam & Newtek NDI troubles



  • Hello,

    I have 2 problems/questions, about the same subject. I am using for some years now Epoccam on iPhones via routeur and Syphon, and quite happy about it despite the visible lag and a few bugs. But on the new project I am working ( and the "new" laptop I am using, a MBP 13' early 2015 with 8go ram) I get very often ( but not always) a very much important lag if ( and only if ) Isadora is in front and Eppocam receiver in background. If I put Epoccam in front, it instantly resync the vidéo. The problem is I am leaving my laptop very often in the show to use camera, and I can easily forgot to put Epoccam in front before to leave it after a transition in Isa, for example. Any idea about the reason, or a way to tell to my system something like "keep the priority on Epoccam even if it's background" ?

    Other question concern Newtek NDI cam on iPhone ( or Android), supposed to be a great alternative with almost no lag . I bought the soft but impossible to make it work with any of the supposed receiver on the Mac ( with an iPhone 7 and a Samsung Galaxy A3 2017) . In NDI Syphon, OBS or NDI viewer ,  I can see the soft is detected in the list, I activate it but just get a black screen. It seems on different forums I am not the only one with the problem, but cannot find any comprehensive issue... PS : I have used successfully NDI Syphon thru my router to send a video from Isadora on a Mac to Isadora on another Mac... Thanks for your help!



  • @laurentr I can maybe help with the NDI part, the recent changes in the NDI SDK make apps using the older SDK incompatible, check for updates all round, stuff made by newtek that is up to date should work together. I am not sure if NDI syphon is using the latest version. If you can ditch epocam for NDI you will be further ahead.



  • @laurentr

    I can maybe help with the background issue. I had the same with black syphon:

    This is related to the App nap energy saving function in OSX. You can check if an Application is using this, in the activity monitor adding 'app nap' to the shown rows. You can find a description about how to disable it here: http://osxdaily.com/2014/05/13...

     



  • Thank you very much for your answers. 

    Dillthekraut, I check AppNap and it's activated when Epoccam is in background, so it's most probably the reason! I deactivated it and will try in rehearsal this afternoon.

    Fred, I gonna check more, may be also about the router settings, but if I don't use NDI Syphon, I don't see how I can get the video in Isadora ( Mac ). Other chats in the forum about it did not give me any solutions...



  • @laurentr I mean to start with, just using Newtek software to identify your problem. If you get connection between the phone and a newtek receiver you know your network settings are good. From there you can see if you get it into NDI to Syphon.



  • @laurentr

    I use the app from an android and always open Newtek NDI Cam app first and pulse the white dot until it changes to red. Then I open the NDISyphon application. Another thing that is important is that the phone is connected to a single network and the laptop is also (the same). I usually disconnect my mobile's data service.
    I hope it can help.



  • After a full day rehearsal, it seems the lag issue of Epocam was AppNap indeed! Thanks again DillTheKraut

    About Newtek NDI, Jandraka advice makes me try different way of starting the devices and finally get the signal in NDI Syphon and Isadora. But when I try a little later, it was impossible to get it. Leaving and restarting several time each devices makes it finally work again, leaving me in perplexity... Have to try more later.

    But I realize also my TP-Link router Archer C60 with its 867 Mbps speed is probably not strong enough to deal with the full quality video without important lag...