• Hi,

    I am in the process of weaning myself off of quicktime in anticipation of V3. I just went to do some tests and AVIs will not play back at all with "Playback Windows Movie Formats Natively". I tried Hap and Uncompressed AVIs in addition to trying the propellerheads sample footage to no avail. If I untick "Playback Windows Movie Formats Natively" it plays fine using the quicktime engine.

    In addition, the test clips play back fine using VLC.

    Would anyone have an idea where I might begin to investigate this issue? I'm stumped.

    Best, J

    Clips:  https://www.dropbox.com/sh/s59...
    Specs: W10 Pro 1709 build 16299.402 8c@4ghz/64gb, gtx1080, NVMe storage. Isadora 2.6.1.

    Fresh install of the propellerheads HAP AVI codec.

    Fresh preferences for Isadora

  • Tech Staff

    I have no problem running your attached files.

    They will not play via QT (when 'play natively' is set unchecked).

    The 'pb engine' output of the Movie Player should read 'DS'

    It may be possible that you are missing a related library that the Hap Avi codec uses.

    The fact that your Hap Avi file you compressed is being read correctly tells me the codec is installed and working on the machine that created it.

    I did notice that changing the setting in Preferences, required me clicking off and back onto the scene I was using for testing.

  • Hmm. I am a bit stumped. I uninstalled and reinstalled the renderheads HAP DS codec, restarted, opened a fresh project and loaded in the sample clip from renderheads. When  "play natively" is checked, the clip just hangs. When unchecked, it plays using the QT engine.  I tried toggling visibility on the clip, and checking/unchecking play natively. I wonder if there are any additional DS components required. I get the same result with HAP compressed AVI and an uncompressed AVI. I wonder if I am missing some DS component or if there is a conflict somewhere in my system.


    I just updated my Nvidia graphics driver to the latest, clear out the Troikatronix folder in %appdata%, uninstalled Isadora and reinstalled it. The issue persists.

    - J

    Play natively unchecked>

    Play natively checked>


    I went on a long overdue uninstall binge and found the issue finally. 

    LAV Filters - ffmpeg based DirectShow Splitter and Decode

    Everything is working as it should now. I had the LAV filters installed for some ffmpeg work I was doing. I don;t think I need them for anything at the moment, but will flag this for the future.

    - J