assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

How to Use Alpha Channel



  • I have searched the forum and the manual but can't find an answer to this simple question.....how do you get Isadora to use a PNG file's alpha for transparency? If i plug a Picture Player into a Projector (or 3D Particle) and set the projector blend to Transparency the PNG is not displayed with it's alpha i.e the transparency is renders as black.


    Thanks

    Tom


  • Beta Platinum

    @wizardofoz

    Hi Tom,

    Is this Mac or pc?

    I would be going back to Photoshop and ensuring that the image is being exported without additional layers being combined and that the transparency is fully resolved in the export/save as dialogue.

    Best wishes

    Bonemap 



  • Hi Bonemap,

    If I "Save as" to PNG from Photoshop Isadora does not see the transparency, the image has only one layer. If I export a PNG from After Effects it does see the transparency. 

    Tom



  • @bonemap said:

    @wizardofoz

    Hi Tom,
    Is this Mac or pc?
    I would be going back to Photoshop and ensuring that the image is being exported without additional layers being combined and that the transparency is fully resolved in the export/save as dialogue.
    Best wishes
    Bonemap 

     this is Mac 10.13.6 & Izzy 2.6.1



  • OK, not sure whats going on....it wasn't working, then working and now not working again. Using the same files!


    I am doing some systematic tests and will re-post results.

    Tom


  • Beta Platinum

    Hi Tom,

    I have just done a quick test with an PNG 'save as' from Photoshop: It all looks OK in this simple patch using Isadora 2.6.1.

    What other effects/actors are you using inline with the PicturePlayer?

    best wishes

    Bonemap



  • After a few hours testing the transparency issue is linked to the media image size, the Isadora Video Preference "Default Resolution" & "When Combining Video" is set to "Scale to Default Resolution". I have added a link to a Zip containing the Izzy file, source picture files, two screen grabs of the results and one of my Video Preference settings. This also seems to effect transparency elsewhere like the 3D Particle actor.

    1. With Default Resolution at 1920x1080 and "Scale to Default Resolution" = 1920x1080 PSD has transparency and the 1280x720 does not.

    2. With Default Resolution at 1280x720 and "Scale to Default Resolution" = 1280x720 PSD has transparency and the 1920x1080 does not.

    3. Changing "When Combining Video" to either "Scale to Largest Image" or "Scale to Smallest Image" the issue goes away.

    I still can't account for my previous experience of the transparency working and then not working simply after replacing a Picture Player in the Izzy file and nothing else. So the issue might only be displayed intermittently.

    DOWNLOAD FILES

    Tom


  • Tech Staff

    @wizardofoz said:

    After a few hours testing the transparency issue is linked to the media image size, the Isadora Video Preference "Default Resolution" & "When Combining Video" is set to "Scale to Default Resolution". I have added a link to a Zip containing the Izzy file, source picture files, two screen grabs of the results and one of my Video Preference settings. This also seems to effect transparency elsewhere like the 3D Particle actor.1. With Default Resolution at 1920x1080 and "Scale to Default Resolution" = 1920x1080 PSD has transparency and the 1280x720 does not.2. With Default Resolution at 1280x720 and "Scale to Default Resolution" = 1280x720 PSD has transparency and the 1920x1080 does not.3. Changing "When Combining Video" to either "Scale to Largest Image" or "Scale to Smallest Image" the issue goes away.I still can't account for my previous experience of the transparency working and then not working simply after replacing a Picture Player in the Izzy file and nothing else. So the issue might only be displayed intermittently.DOWNLOAD FILESTom

     Please create a support ticket using the link in my signature.



  • I have logged a ticket.


    Cheers

    Tom