assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

Use of 4 screen Preview without Ruining the frame rate in 1080i50



  • Dear All,

    I need your help with a patch I use for a show on a macbook pro with 2 media player, 2 blackmagics Design USB3 inputs, 2 outputs on 2 beamers in HDMI. Here is a link to the teaser of the show : https://vimeo.com/255046917

    I have difficulties to obtain a frame rate of 50fps (seems to be needed by the media player to obtain a good fluidity, even if the medias are in 1080p 25fps). Vertical sync issue ?

    When I activate stage 6 to have the preview, the frame rate drop to 35 fps, due to use of four 1080 videos to generate thumbnails for the previews (needed to see what's going in the computer).

    It would be great if you could help me to optimize the patch (I tried to decrease resolution in the patch before linking linking to preview, but it's worse).

    Thank you for you help.

    Kind regards,

    Benoit

    2018-11-21 VDP BETHUNE.izz


  • Tech Staff

    Dear @webmammuth

    Did you read through this article? https://support.troikatronix.c... Does this help?

    Best Michel


  • Tech Staff

    How many cycles are you getting when you run your show?
    What codec are you using for your videos?
    Have you checked what your GPU usage is looking like? 



  • @michel,

    Thank you for you answer. I've read the article. The 2 mains outputs can't match the requirements this article is about, since they are not in the same resolution, and not the same orientation.

    It's the third dispaly (6th stage / Floating window) that pose problem. Without the preview, everything is smooth.

    I try to find how to have this preview without running 4 fullhd calculations.



  • @DusX thank you, there is approximatly 100 cycles. 38 fps when running with 1 media players / 2 live inputs. It reaches 50fps when no medias are playing. Or when inputs are not on (live capture off).

    Video are in prores 422.

    I will check the gpu usage as you suggest.

    I'm searching for a solution to have lower resolution for the previews, but since every calculation is on 1920x1080, the previewing is runnning at full resolution.



  • @webmammuth

    Hello, If you play your médias at the nominal speed, I recommend H264, it's really more efficient with a good graphic card, compared to Hap. ProRes is in third position and you cannot play them on windows. With an SSD, I can easily play 4 flux.

    But I cannot really compare because I have no live capture.

    Jacques



  • @jhoepffner said:

    Hello, If you play your médias at the nominal speed, I recommend H264, it's really more efficient with a good graphic card, compared to Hap. 

     Jacques, would you suggest that this is also true on Windows?

    Thanks,

    Hugh



  • Yes, its true on window if you use the good wrapping, .mp4 is working for me. With nVidia card, you have hardware decoding.

    I use Hap only when I need alpha or changing speed.

    Jacques


  • Tech Staff

    @jhoepffner

    I would like to know what mp4 settings you are using so that you see gpu decoding in Isadora 2.6.1
    I am unable to reproduce this behaviour. Watching my GPU performance tab in the Task manager, show 0% video decoding, only gpu 3D usage.
    I have tested now with ~15 files covering a range of mp4 options.



  • @dusx said:

    I am unable to reproduce this behaviour. Watching my GPU performance tab in the Task manager, show 0% video decoding, only gpu 3D usage.

     There's clearly something odd going on. Why should Isadora be utilising the 3D decoding bits of the GPU at all when it's just playing back video files?
    I've an NVidia GTX980, Windows 10 Pro. Based on some experimenting with that:

    I can take any video file, and play it back in Isadora, and it shows approx 15-20%  usage in the 3D panel of Task Manager GPU.
    If I hide the stages that usage goes up to about 27%. That doesn't seem right.
    .MP4 files are the same as any others.

    I, too, would be curious to know what @jhoepffner's results are like.

    Play back an .mp4 file in Windows Media Player, it shows about 4% usage in the Video Decode Panel, nothing in the 3D panel.
    Play back the same .mp4 file in the FIlms and TV app: 4% usage in the Video Decode Panel, nothing in the 3D panel.
    BUT if  I play the same file back in VLC (with the preferences reset to default), it shows 4% usage in the 3D panel, nothing in decode.

    All these results the same in GPUz as in Task Manager.

    Rendering a scene with the 3D Model Particles actor employed shows the GPU 3D working hard, as I'd expect.

    NB all my .mp4 files are made in Adobe Media Encoder.




  • @mark_m @DusX 

    I make a confusion between encoding and decoding. On TD its possible to use hardware encoding with nVidia, There is a possibility with nVidia to use hardware for decoding but its not used in TD as in Isadora.

    With Task Manager, the load on CPU/GPU are quite exactly the same between h264 and Hap and the same between Isadora and TD. I have to make more extensive test with a bigger load but I will take an early train tomorrow to perform north of France, I will do it next week.

    Concerning 3D, it's perfectly normal, because for performance reason, Isadora as TD use 3D render on GPU to have a fast render, it just use a rectangular viewport with the screen dimension, an orthographic camera and a constant material. GPU are made to deal with vec4, matrix and UV texturing. 2D is just a point of view on 3D…

    If you force your application to use nVidia card (in nVidia settings, you can see also a 3D GPU usage. For example, just now, if I use Kyno (a media manager), if I play a video, there is a very short use of 43% of the graphic card, with GPU1-3D writes. If I stop, after 5", its 0% with nothing written, as reduced to the intel graphic card. But Firefox dont use the graphic card but write GPU1-3D.



  • Hello Everyone,

    I wasn't able to find the gpu history window in activity monitor (cf screencap)...

    I'm surprised that the cpu is only 50% charge.

    In isadora, not all processes use gpu.

    All my screens are connected to the nvidia geforce 750m.

    I have around 80 cycles in isadora with 2 captures and 1 movie only.

    Tried h.264 but no increase of fps.. 

    Any ideas to help me?

    Thank you 😉