assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

Layered videos without blending black backgrounds?



  • Hey there. I'm struggling hard to make a grid of shifting videos but I'll make a separate post about that. I'm trying to layer small videos over a larger background video, but I want to keep the rectangular black background of the smaller videos. It seems it always automatically makes the background transparent no matter what I do. Any ideas?

    Thanks!



  • Not quite sure if I read the question right, but there is a blending mode on the projector, the one you are looking for is opaque. Also the layer of your background needs to be set lower than your overlaying videos when you set everything to opaque.

    I hope that helps, otherwise please elaborate your question and maybe add an example or screenshot



  • Hey, thanks for the reply. Yep, you read it right. I was trying with Opaque but it wasn't working for some reason. I just tried it again and figured it out.

    I was trying to layer a Movie Player over a live Video Watcher feed from another Scene which was triggered by an 'Activate Scene' actor. The Opaque seems to only be working for the Movie Player when the video is in the same physical scene as the Video Watcher.

    My guess is that the layers don't read across scenes?

    Cheers


  • Tech Staff

    Play with these settings.

    >>>Example file<<<

    Best wishes,

    Woland



  • @woland Thanks for the help


  • Tech Staff

    @jsegal99 said:

    My guess is that the layers don't read across scenes?

    The default layering mode does not read across scenes, rather it 'flattens' each scene to provide the cleanest possible scene transition.

    There is another layering mode available, that does not flatten scenes, and provides the cross scene layering you were looking for.
    Note: You can change the layering mode for the entire project only.
    The setting is available Under File/Layering