assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

Jerky video playback



  • Hi everybody,

    I play one video with HAP codec, resolution 4500 x 1080, 25fps and I use IzzyMap to put this video in 3 video projector (all are in 1920 x 1080).

    The patch is very simple (see below). One scene for a video, and I fade in other scene to play an another video. I have 18 video, so 18 scenes.

    Patch

    In preferences, the target frame rate is 25 and all my video output frequency are in 50 hz.

    My computer is a MBP 2018, 15 inches, with 32 go memory. I use 2 usb-c to hdmi adaptator and 1 usb-c to dvi adaptator.

    The problem is : sometimes the video playback is fine, sometimes is jerky… If I read the same scene, it’s random..  Sometimes it’s ok, sometimes it jerk… 

    I notice when a video jerk, I go to preferences and I clic « OK », the video playback become ok…

    Did I miss something ?

    Thanks


  • Tech Staff

    @aphexkiki 

    It might be worth checking that you have the latest Hap codec installed.

    Next to that, the obvious thing is that the files are pretty large, so they require a lot of data bandwidth. 
    When you do a transition (if it involves a cross fade) double as much data is being transferred, so often this is where users will see some stuttering in the playback, as the requirements double.
    Your machine is new and should have a nice fast drive, so this is less likely an issue, but still worth watching  (do you have other things running at the same time that might be using the same drive?)
    It looks like you are not doing any interactive manipulation of the video plaback therefore, I would suggest you change the 'optimize' input to Performance, this should change the Playback engine to AV foundation rather than quicktime (seen at the 'pb engine' output). Give that a try and see if things improve.


  • Tech Staff

    Also try setting the "optimize" input on the Movie Player from "interaction" to "performance" if you're just doing straightforward playback.



  • Hi,

    change "optimize" input on the Movie Player from "interaction" to "performance" doesn't seem to change anything (and I use interaction mode for multi sound output).

    I stop crossfade between scenes, the fade of jump actor is set to 0. 

    I use also preload scene actor (one preload actor for the next scene).

    I also disable full frame antialiasing in preferences.

    It seems to be better now. 

    I'm thinking about the video preload actor, but I can't find it in tools...

    Thanks


  • Tech Staff

    @aphexkiki

    I'm glad to hear performance is improving for your.

    Since you mention that you have added preloading actors, I suggest you read (if you haven't yet) this Knowledge base article: https://support.troikatronix.c...

    It will help you know the limitations of the preload actors (there are some situations where they may not work, or can cause you problems if not used carefully)



  • I already read this article, and it's very helpful ! Thanks

    But where is the video preload actor in Isadora ? I just find scene preload actor.


  • Tech Staff

    Video Preload has been depreciated and is thus hidden by default. Using it is not recommended, but you can unhide the classic actors by going into the first tab of the Isadora Preferences and uncheck the box next to "Hide Depreciated (Classic) Plugins From Toolbox".


  • Tech Staff

    @aphexkiki

    The Scene Preload will load Videos that have their Id loaded into a Movie Player (as outline in the article I linked).
    That is the recommended method, but as Woland has mentioned, the depreciated Video Preload actor is still available, but requires even more care be taken to avoid filling your RAM with unused media.



  • Ok, no video preload, only scene preload.

    Thanks