assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

[SOLVED] MIDI Show Control Watcher not working while MSC Cue triggering does



  • It's been about 2 years since I programmed my last Isadora show, so I'm a little rusty. On my current patch in Izzy 2.6.1 (running on MAC 10.11.6) I have MSC triggering my scenes from an ETC EOS- and that works just fine. Thanks for building in that functionality now!

    But I have some Midi Show Control Watchers in a few scenes to trigger internal events. For some reason those don't seem to be seeing any of the MSC events coming from the light board. In the past I always used the MSC Watcher with Bengali's Jump by Name to trigger my whole show, so I've had success using this watcher in the past. I'm just not sure now why it isn't working for me now. Especially since the MSC scene triggering functionality works fine.

    I've tried messing with the MSC Watcher's port, device ID, command format, and command all to no avail. The MIDI interface is correctly set (as Port 1) in the MIDI setup screen.

    Thanks,

    Barry


  • Tech Staff

    • Check the settings on the Ion and made sure it matches the Device ID on the MSC Watchers
    • Set the format to Lighting
    • Set the Cmd Format to "Lighting" (grab the input and scroll it all the way to the bottom)
    • Set the command to "Go"
    • Maybe also place a MIDI Enable actor and trigger it once?

    A quick test from QLab with MSC Lighting Go messages for Cue 1 and Cue 2 with Device ID 1 and MIDI Destination as "Isadora Virtual In" had this working for me immediately.


  • Tech Staff

    This post of mine should also be able to walk you through the process of doing this (with all the steps): https://community.troikatronix...


  • Tech Staff

    @barrysteele

    Have your tried viewing incoming messages using Isadora's Monitor window?
    If Isadora is receiving the message and just not responding due to a small config issue you should be able to determine the fix from the info shown in the Monitor.



  • Thank you Woland! You know so much about MSC... I was already aware of your posts. : )

    It was the Device ID in the EOS. Once we set that from 0 to 1 suddenly I had communication to the Watchers. I was thrown off by MSC working for triggering scenes and so thought all the MSC settings in the EOS were correct.

    Thank you for your thoughtful reply.

    Barry