assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

[ANSWERED] How to disable tooltips + Mojave upgrade



  • Hi,

    I was forced to move to OSX Mojave because Apple changed my MacBookPro to a new one (MacBookPro 2018, Mojave, 2.6GHz i7, 32GB RAM, RadeonProVega20) – the previous (late 2016) was repaired 4 times before change. Isadora is crashing sometimes in strange occasions, but otherwise no problem working with it in Mojave – but I suppose the crashing occurs due to Isadora v2.6.x not being tuned for Mojave? (looking forward to v3 soon)

    However, in the meantime, I would like to know how to disable the tooltips (appearing when hovering over an object) – I find the tooltips a bit annoying. 

    Also, is there a way to disable the info window on the low right corner of the interface? I've really never needed to use that info. (I know I can just drag the window frame down, but maybe there's a way to disable that also?)

    Thanks in advance!


  • Tech Staff

    @lauri said:

    Also, is there a way to disable the info window on the low right corner of the interface? I've really never needed to use that info. (I know I can just drag the window frame down, but maybe there's a way to disable that also?)

     This can be turned off by going to View>Information in the menu bar at the top of Isadora. 



  • @Skulpture Thank you for your advice! Of course, my carelessness, sorry.

    But I would still want to disable the tooltips, would that be possible? If not in Isadora v2.x.x, please could it be an option in v3.

    Thanks!


  • Tech Staff

    @lauri I don't actually know about the tooltips... @Woland any ideas?


  • Tech Staff

    @lauri said:

    But I would still want to disable the tooltips, would that be possible? If not in Isadora v2.x.x, please could it be an option in v3.

    Not quite sure why you'd want to disable them, but I don't think you can in Isadora 2. 

    In Isadora 3 there's an option in Preferences to set the amount of time it takes before a tooltip appears, you you could just set that to the maximum value and you'd likely never have tooltips come up again.

    Best wishes,

    Woland



  • @Woland Thank you for your reply!

    It’s true that sometimes it’s handy to have the tool-tip info, for instance actor input/output value info, or actor’s input/output name when actor is collapsed.

    However, if I put the mouse cursor over an actor in the “Toolbox”, it says “Click to select, then move mouse to editor and click to deposit”. This tip has no value for me and it displays over the actor name covering it all or part (depending cursor location).

    Also, sometimes after hovering over an actor and moving cursor elsewhere, the tip message comes visible there (the new location of the cursor that might be outside the interface area) and stays there for a while even I move the cursor. This happens at least when having an external monitor hooked on a MacBookPro. (Well, this misbehavior might be part of the misfit between Isadora v2.x.x and Mojave?)

    Lauri