assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

[ANSWERED] 3.0.1 publishing mapping points/fps/GLSL



  • Hi,

    congrats to Mark and the team to finally offer Izzy 3!

    Admitting I'm on 10.10 or 11, here my findings:

    No more publishing mapping points from inside projector mapping? Tried any possible keyboard combination, no luck.

    No matter what I set in Preferences, 15, 60, 120 - status bar stays at fps 30something.

    GLSL. Downloaded the  TT shaders to the desired location, all I get is


    without arms and legs. Double-click says


    May this awesome community shed some light.

    best r



  • @reinhard said:

    1) I just opened 3.0.1, right clicked on a point in IzzyMap and published it. I then modified it with a Wave Generator. So for me this is working.

    2) I also put the GLSL Plugins in their proper location and the do what they are supposed to do, but I didn't download them. Sorry to be stupid, but where's the download location (the team set this up, not me.) It's weird that it says "book" inside -- that's wrong.

    3) One of the things I didn't get to for v3.0 due simply to lack of time is a "?" button in the frame rate settings. One of the new features in 3.0.1 for MacOS only, is the ability to lock Isadora's frame rate to the external monitors.


    This is handled by the Display Refresh Lock control. You have three choices:

    Scaled -- where it will take the monitor refresh rate and scale it down to an even multiple that falls within the 24-30 fps range. (For example, a 75 Hz monitor becomes 25 Hz.)

    Full - where Isadora will lock is render frequency to the display's render frequency

    Off - where Isadora goes back to using the Target Frame Rate as it did before.

    Windows doesn't offer a similar mechanism, but improved all kinds of things to do it this way on Mac OS. 

    For sure this setting is crypic. I figure there will be something that pushes to create a 3.0.2, and I'll add further information in that dialog area so it's clear.

    Best Wishes,
    Mark


  • Tech Staff

    @reinhard said:

    No more publishing mapping points from inside projector mapping? Tried any possible keyboard combination, no luck.

    Works fine for me when I go inside the Projector and right click a point to publish the X or Y.

    http://recordit.co/5AR28tiO10

    GLSL. Downloaded the  TT shaders to the desired location, all I get is without arms and legs.

    1. GLSL Plugins can be downloaded from the Plugin page (and they even come with instructions on how to install them): https://troikatronix.com/plugin/tt-glsl-shaders/
    2. The file path for Mac is /Library/Application Support/TroikaTronix/GLSL Plugins
    3. You can also open the correct folder to drop them in by opening Isadora, going to the menu, and select Help > Isadora Plugin Folders > TroikaTronix Shaders
    4. Make sure to close and re-open Isadora after you put these plugins in that folder so that Isadora can register that they're there.
    5. I'm running 10.11 (El Capitan) and it's working fine for me. 
    6. The "Book" thing is a complete and utter mystery to me.

    Best wishes,

    Woland

     



  • On my 15inch MBP 2017, 2,9Ghz i7, High Sierra  I can publish coordinates when using a mouse with a physical right click, while I have no luck using my trackpad or apple mouse and pressing control on the keyboard, which usually simulates the "right click"....?


  • Tech Staff

    @tomthebom

    I can recreate your problem with the trackpad, ctrl+click does not work it does with 2.6.1 but not with version 3. What does work is clicking on the point to publish with two fingers on the trackpad.

    So this would be a bug, not able to control click to publish.

    Best Michel



  • Many thanks to @tomthebom and @Michel  for saving me an unnecessary upgrade!

    @mark @Woland GLSL - my fault, accidentally made aliases when moving the files.


  • Tech Staff

    @michel said:

    I can recreate your problem with the trackpad, ctrl+click does not work it does with 2.6.1 but not with version 3. What does work is clicking on the point to publish with two fingers on the trackpad.So this would be a bug, not able to control click to publish.

     I am adding this to our issue tracker.