assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

Detect Serial Ports (again)



  • @juriaan 

     Indeed I have the 32 bit plugin, IM running Izzy 2.6.1

    Good to know for the serial. But still Isadora does not seem to output Artnet in a way that is readable for my ENTTEC. I'm intercepting paquets with wireshark and and I'm not having the reading I should...  Also the statistics from ENTTEC of the web panel shows me I don't send info from isadora.

    I'm working with the tutorial file from https://support.troikatronix.com/support/solutions/articles/13000042899-controlling-led-strips-via-artnet

    But still no dice. Any cues on what might not be adressed properly? Once again, I can ping it + I can control it from other software except IZZY.

    Thanks

    Kir


  • Beta Platinum

    Don't you get any readings at all or are you getting readings that aren't right? If you could share your patch / the images what you receive (Wireshark / Enttec panel) we can try to give you a hand.



  • WireShark + Patch

    Hopefully you see something

    Kir


  • Beta Platinum

    Hi there Kir,

    I see that you are broadcasting your ArtNet data instead of sending it directly to our Node (Your request end with .255 instead of directly to the IP adress of the node). I also see plenty of ArtPoll request coming through the device.

    What you can try it with Isadora set the intf adress field to the IP that you can find in the Browser Configuration Home panel of the device. Please see the manual of Enttec how to get there.

    Also please make sure that no other programs (Including the browser configuration page) are still open when you try to connect with Isadora, it could be that multiple programs are sending data at the same time causing the device to become confused.


    Let me know or that works.



  • Ok I'll try that! Although I already tried to adress the intf adress to the device IP and the Artnet Broadcast simply stops (observed by WireShark).

    Do you have a patch you could share?

    Many thanks

    Kir



  • Ok so I made it worked.

    The only way was to put the device in the range x.x.x.255.

    Any other specific IP was no listen (and believe you me I tried)

    Although I can't access the web panel anymore, due the fact that the device is now in .255

    If I change the input (intf adress) by anything else then blank, the broadcast stops.

    Hope you guys can look in to that, because I feel that was wildly complicated for a simple use of ArtNet.

    Thanks for your help!

    Kir


  • Tech Staff

    @kir

    With you art-net node connected to the network, can you add a new 'ArtNet Send' actor to a scene, and try clicking in the empty 'node name' input field.
    Isadora uses art-net discovery, and will generally list any connected art-net nodes. 


    That is all I need to do to connect to a node. 

    Of course this assumes that you don't have many network interfaces connected to your machine, and that the 'intf addr' output address is the correct IP for the network interface you want to connect to.
    If it is not, you will need to add the correct IP for the 'intf addr' input.



  • @DusX no discovery was ever made in node name (once again believe me I tried and check again and again).

    I've been using Artnet protocole in many softwares and with many devices, so it's not my first barbecue.

    Still it took me a day and a half to figure this out with the help of @Juriaan, and the fix is only so-so. I wish Isadora would have a more integrated way to use Artnet or DMX.

    The fact is, I was never sure Isadora was seeing my device (ODE MK2 - ENTTEC). So I was kind of shooting in the dark. I hope some more advance and/or intuitive tools will be coming out in V3.

    Many thanks 

    Kir


  • Tech Staff

    @kir

    What does your network config look like?
    Do you have any configuration software for the MK2? Does it supply the 'intf addr' ?

    I dont have a MK2, so I can't say how it works with art-net node discovery, but I have nver had an issue with any of my devices.
    Are you assigning static IP addresses or using  DHCP network addressing?



  • @kir said:

    Still it took me a day and a half to figure this out with the help of @Juriaan, and the fix is only so-so. I wish Isadora would have a more integrated way to use Artnet or DMX.

    Mark here. I just wanted to say I'm sorry you faced this frustration. The implementation of ArtNet is relatively basic, and we haven't put loads of energy into it because we don't have a sense that ArtNet is important for the bulk of Isadora users. Given that we have limited resources, we have to focus our energy towards the items that are most valuable to the most people.

    That said, @DusX on the team uses ArtNet frequently so he is a fan, and this means you have someone who will push for a better implementation on the team. From my side, I want to see every feature in Isadora be as easy and robust as possible, beause every capability Isadora offers is increases its overall value. Please continue to offer your feedback. I and the team are listening, and we can revisit what your requests Isadora Werkstatt and see what can be done.

    Best Wishes,
    Mark