assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

... Play movies with multi-channel audio



  • Hi there.

    Notice that i use Windows, Isadora 3 and a Scarlett 18i20 2Gen

    I need to play movies with Multi-Channel Audio. So i did an appel pro ress LT with 6 audio channels.

    When i play the video in Isadora, every channel are mixed on a stereo.

    I read the manuel but i Don't find how to send each audio channel to his how output. 
    I read i that i have to use Audio Video Player, but i'm not able to find it.

    Regard's

    Martin


  • Beta Platinum

    @martinm

    So if Im not mistaken it is not really possible without some major workarounds. During the beta some users worked and tested different configurations. Tagging @Fred here, perhaps he can share some of the research that he did to this topic


  • Tech Staff

    @martinm

    Here are two links were @Fred was talking about how he got it working:
    https://community.troikatronix...

    Best Michel


  • Beta Platinum

    @Michel 

    The last thread is in a closed part of the forum, the OP is not able to reach it


  • Tech Staff

    @juriaan

    ok thanks. I deleted the last link.

    Best Michel



  • Hi, 

    Thank's for your responses.

    Windos doesn't recognize my sound crad as a 5.1 neither 6.1 so it seem complicated.

    I tried on mac mini using apple pro ress LT 6 channel.

    I set up my sound card as default (Scarlette 18i20 2 gen) 

    I set up the menu "sound output setup" (channel 1 : Ext 1-2, Channel 2 : Ext 1-2 and so on)

    In the player, i choose, Audio Trks : 6, Audio Device "Scarlette", 

    Trk1 pan 0, out e1-2, Trk2 pan 100, out e1-2 ... and so on.

    Optimize, interaction

    Pb engin in QT

    When i play my movie, it merge all my tracks in ex 1-2 ... 

    Can you help me ... i'm going crazy about it ...

    Thank you a lot

    Martin


  • Tech Staff

    @martinm

    I don't have a multi channel Soundcard but I tried it with Dante virtual Soundcard on Mac. Go to Isadora Menu "Output-->Sound Output Setup" and click on the top button "set default sound output device". The audio device setup of the system opens, there you have to select your sound card and configure your speaker by clicking on the button at the bottom right side. I did not have to set anything more for it to work. Just pulled in the movie with 6 channels and the default settings of the movie player worked out of the box.

    Best Michel



  • You can also choose the audio output device it in the Movie Player if you expose the 'audio device' input. Learn more here.

    Best Wishes,
    Mark


  • Tech Staff

    Quoting @Mark from another thread:


    If you double click the "eye" icon on the movie player, and enable 'audio device', 'snd out' and 'audio trks', you'll see these options. 

    Right now, these channel related inputs currently only function on MacOS if you set the mode to 'interactive' -- which means you are using QuickTime to play the movies.

    If you set the number of 'audio trks' to three, the Movie Player looks like this.

    The audio device input allows you to send the sound to a specific output device. The 'trk' inputs specify the volume, panning, and routing for each track.