assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

[Ticket Submitted + ANSWERED] Isadora lagging severely



  • [A ticket has been submitted and this is being handled there.]

    Hey everyone, sorry if this has been asked before but I've been finding trouble when displaying stages in Isadora 3. Attempting to do so only with a Video IN and a Projector willcause the program to lag severaly, dipping below 0.3 FPS, and the load to go up to 5000%.

    The video codec is HAP, AVI format, with good resolutions but not too heavy and interactive response is good. I've disabled Creative Cloud and nothing seems to work.Have you got any ideas on what might be going on?

    Cheers


  • Beta Platinum

    Hi there,


    What is your operation system ? If you have double graphic cards it can be that you need to force Isadora to use your dedicated graphic card instead of the one at your motherboard.



  • @camilajaime said:

    Hey everyone, sorry if this has been asked before but I've been finding trouble when displaying stages in Isadora 3

     We need more details to help you. But before that, please read this thread about compressing HAP video on the PC.

    Also, on Windows, it is important that your video drivers are up to date. Please ensure that's true for your system.

    1) Isadora Version
    2) Operating System and Version
    3) What is the resolution of your HAP files and how did you compress them? (It seems the method of compression can cause issues)
    4) What camera/device the source of your live video input? What is the resolution?
    5) How many stages are you attempting to show? Just one? Or More?

    If you want the most direct and fastest support possible, open a support ticket with the details requested above and mention this thread. We'll update it once we help you find a solution so that the entire community can benefit.

    @DusX -- please monitor this thread.

    Best Wishes,
    Mark



  • @Juriaan  Hey, thank you for your reply and sorry for the delay in getting back to you. I'm using windows 10 64bits and since it's a notebook, there's only one graphics card, an intel HD graphics 4000. Do you think any of this is related?



  • @mark Hey Mark, sorry for the delay and thank you for replying. I've read the forum post you linked and I believe we might be getting close to the issue. Here's the info you asked for: 

    1) Isadora 3.0.2

    2) Win 10 64 bits

    3) Resolution is 1920x1080 normally, but i've tried to make them smaller to see if pixel density was the cause of the high load. Some of the videos were obtained from the internet and some filmed by a friend. When making them smaller or changing compressions I used Camtasia Studio as a quick rendering tool. 

    4) Some of the videos were recorded with a Nikon Coolpix P600. Resolution is the one stated above, 1920x1080. 

    5) Just one stage. 

    I'm trying to re-render some videos, trying combinations of HAP enconding with .MOV and .AVI file types to see if something works. I'll let you know if something does. 

    Cheers.



  • @camilajaime - definitely re-render all the videos to the same codec and wrapper. On Windows try HAP and AVI. You may find that solves the problem -  codecs in files from the net are treacherous. 

    Try using Shutter Encoder to do the rendering, if you're not already using something professional - it's free and it's used by many people here. http://www.shutterencoder.com/en/

    You probably don't need to render to HD. 720P is probably good enough. Are you using an HD projector? 

    It may be that your Intel graphics adaptor is holding you up (?), but I would have thought that playing a single movie on a single stage would be okay. I don't really have any experience with those kinds of graphics adaptors. 

    Finally, make absolutely sure that you have all for the fancy graphics in Windows turned off as well as any bloatware that came with your computer! https://www.thewindowsclub.com/disable-visual-effects-windows

    Hope this helps!

    Hugh



  • @camilajaime

    @CitizenJoe 's advice is the same as I would give. Most importantly, switch to HAP if you have a fast SSD drive on your notebook. (HAP files are big; for them to work well, you need a good SSD.) Without knowing what codec is inside those Coolpix P600 and how they are compressed, re-encoding becomes more important.

    That said, unless you have a really slow/older machine, 1080p should not be a problem. We have tested extensively with HD and have also had success with 4K files.

    But if this problem persists for you, and if you can see this problem when simply fading (for example) from Scene A with a single 1080p movie to Scene B with a second, single 1080p movie, then I would suggest it's time to open a ticket and provide our team with a) your patch, and b) those two pieces of media that demonstrate the problem. Giving us concrete materials like that is generally the fastest way to find out why you are having trouble and to come to a solution.

    Again, the URL for opening a ticket with tech support is https://support.troikatronix.c...

    Best Wishes,
    Mark


  • Tech Staff

    @camilajaime said:

    it's a notebook

    I know you said you only have one graphics card, but please walk through these steps just to be sure. This is a crucial manual change that must be made for most users with Windows laptops: https://support.troikatronix.com/support/solutions/articles/13000064926


  • Tech Staff

    [A ticket has been submitted and this is being handled there.]