assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

Capture Camera to Movie Issues in Windows



  • Hi all,

    I recently switched to a windows 10 desktop from using a Mac mini to run this show I'm opening tomorrow (so unfortunately this is kinda urgent). The Capture Camera actor does not seem to be working. Everything populates in the bin correctly but when I try to play back the file Isadora won't play the it and when I look at it in Windows Explorer the file is all sped up. I think it has to do with the codec but I can't find where I address the codec for this record (I can only find the codec adjustment for the record stage actor). Has anyone experienced this before and if so what are the workarounds/solutions? Any help would be beneficial!

    Isadora 3; Intel i5; Nvidia 1080i; Magewell USB to HDMI capture device


  • Tech Staff

    I think it is likely you are having issues with codecs.

    These are the codecs I have tested, and the related cpu load I saw for each.

    CODEC

    CPU usage

    DV video encoder (DS)

    34%

    Hap (vfw)

    52%

    HapA (vfw)

    53%

    HapQ (vfw)

    53%

    Intel IYUV (vfw) *

    28%

    MJPEG Compressor (DS)

    46%

    MSScreen 9 Encoder (DMO)

    46%

    MS Video 1 (vfw)

    31%

    WMVideo8 encoder (DMO)

    47%

    WMVideo9 encoder (DMO)

    47%

    Black Magic HD 8 bit 4:2:2

    27%

    Black Magic 8 bit MJPEG

    30%

    Black Magic 10 bit 4:4:4

    30%

    Black Magic 10 bit 4:2:2

    28%

    Personally I found the Black Magic codecs to work best for me. Both the CPU load was low, and the quality was good.

    The codecs are only installed along with the Black Magic Desktop Video Software 11.x. 



  • Awesome, yeah that was what I figured as well. Unfortunately, I don't seem to know where to change what codec is being used. Do you have any insight?


  • Tech Staff

    Go to menu:
    Output / Record Stage Settings...

    The movie settings are what you need to work with.

    note: a known issue, is that sometimes you may find a codec causes a error (sometimes due to write speed or compression time).
    In anycase, the error will stop you from being able to make additional changes, but it will look normal.
    If you get a codec based error, I suggest re-starting Isadora right away.. it will help you avoid frustration.

    Improving this feature is on our roadmap.



  • Thanks for that info. So I adjusted the codec and the file is still being recorded as a MJPG. Adjusting the codec does not seem to be making any difference. Have you encountered that before?


    I'm glad to hear that this is on the docket to be improved. On the Mac, I ended up using this feature a lot and am considering shifting fully over to windows for my isadora work.

    Thanks in advance!


  • Tech Staff

    @wwachalovsky

    Note, all files are saved as AVI files. 
    Perhaps you need to restart Isadora for your changes to be applied. I have had issue making changes, generally after a failed change (with or without error).