assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

Two days before show with distorted mapping!!!


  • Tech Staff

    @ray said:

    I'm doing the mapping with ae cc 2018

    By this do you mean that you're not using IzzyMap in Isadora but that you've made you mapped your content by rendering the file so that it falls the way you want onto your surface?

    If this is the case, and you're not using Isadora for the actual mapping, my bet is that there's a system or preferences setting somewhere that's different. 


  • Tech Staff

    What's not entirely clear to me from your post is where the mapping is happening. When you say "I'm doing the mapping with AE CC 2018" are you saying that the mapping has been baked into the assets themselves? It's not entirely clear to me to what extent you are using IzzyMap.

    In any case, there is some setting or format that has not been correctly copied over to the new machine. If the mapping is distorted, it may indicate the Mac Mini is projecting the wrong resolution

    You need to be 100% certain that once connected to the MacMini, it's using the exact same resolution and stage settings as the MacPro. This could be in the settings on the projector itself, in the Display Preferences of the MacMini, or the Stage Preferences of Isadora 2.6.1. The settings must be exactly the same or you will get distortion.

    If you are 100% sure the settings are the same and the files are the same, but are still seeing distortion -- check them again. That's the only possible explanation I can imagine. If these steps don't fix the problem, given your time frame the only solution I can recommend to you is that you have the Mac Pro control the show given the tight time constraints.



  • @mc_monte

    I'm making a movie with an alpha channel in after effects using syphon in isadora so I can see the mapping live on the object. Then I import the movie into izzy and set the projector to layer 1 on layer 0 I have another video which runs underneath and partially blocked by the animated alpha video. You can see what I'm doing on my vimeo page. But it must be the settings...


  • Tech Staff

    @ray 

    When you mouseover the link between the Syphon Receiver actor (sending content from AE CC 2018) and the Projector actor, what resolution does it show?


    Does this resolution differ from the resolution that is shown when you mouseover the link between the Movie Player actor and the Projector actor?


    If the resolution of whatever program you're using to get AE CC 2018 content into Isadora through Syphon is different from the resolution of the actual media you're loading in, your mapping will most definitely be off. 

    Also I'm still unclear on whether you're using IzzyMap or not.

    (P.S. Your work looks incredibly beautiful)


  • Tech Staff

    @ray 

    Any joy? Do you still need help?


  • Tech Staff

    @ray

    Any news?



  • @ woland 

    Thanks for checking out my work. Sorry for the slow response, been too busy with the show set up. I tried the white screen fix without success. In the gallery I have 4 projectors connected to a mac pro and two projectors connected each with its own mac mini. Each computer also has a monitor, keyboard and mouse. I have an AE file for each physical cardboard object prepared beforehand so I can simply pull the mask into the new correct position using AE. When finished, I render out a 2 sec. loop with an alpha channel then import this into Izzy and it looks great. The next time I open Izzy on same computer I did the original mapping on the 2 sec. loop video is no longer accurate. Have resorted to not turning off the computers just the projectors but this is also not 100% foolproof, had to remap and re-render one object. Am using Izzy Map to correct the alpha videos if the aren't too far off but essentially the mapping is done in AE. How would I do mapping this complicated in Izzy, take a shape actor the distort it in Izzy Map for each facet on an object?

    A friend suggested that I wait a half hour till the projectors warm up and maybe it will correct itself. I haven't tried this yet but what the hell I'll give it shot if I have problems again  ; )



  • @ray I had some problems with mapper settings being lost in 2.6 when the changes were small. Can you try making the last movement large and radical just to test if it saves the positions if the adjustments are not small (and try with the mouse not the keyboard, I think there was a difference).

    Sometimes I was able to get over this by having an extra slice that did not do anything (it was out of the source and destination areas) and moving this a lot and then saving. It drove me crazy at the time as the movements I was making were small and I could not tell if the projectors were moving (they were 100m away). 

    This was a bug that was caught but I don't know if it was fixed in 2.6.1 or not until version 3. I also did not test V3 for this.



  • Thanks for all your advice. Am readjusting each projector each day till they're more or less accurate. The gallery is only open two days a week. Am not happy with this solution but surprisingly to me most people don't notice the inaccuracy....


  • Tech Staff

    So just to be clear, you’ve tried the following steps in this order?

    1. Use System Preferences to find the resolution of the projectors.

    2. Create a jpeg that’s just full white at the same resolution as the projectors.

    3. Turn on the computer BEFORE the projectors.

    4. Open Isadora into a Scene that’s just a Picture Player actor outputting the white image to an unmapped Projector actor.

    5. Show stages BEFORE turning on the physical projectors.

    6. Turn on the projectors so that the first thing they “see” upon waking up is the full white image with NO mapping at their native resolution (to prevent them from doing any auto-scaling).

    I swear the problem you're having sounds like the exact issue I was having a few years ago and the steps above solved it for me because it turned out that the projectors were auto-scaling/auto-keystoneing and the only way to prevent it was to send an unmapped image at the full resolution before I turned on the projectors and letting the projectors "wake up" to that unmapped white image.


    Can you please give us the make and model of the projectors? (Also make sure to go into the menu settings for each projector and ensure that you’ve disabled anything like “auto-keystone” or “auto-scale”.)