Possible crop actor bug...



  • I am designing a show where I use heavily the crop actor connected to a MIDI controller fader where the operator can fade in and out a second video stream matching the actors gesture swiping the video screens like an iPad. Anyway, after the first use of the crop actor in the scene the video stream underneath start to flicker in and out. It doesn't do that on my computer screen if I force stage preview. Also pausing the stream underneath seems to solve the problem but I need them running at the same time. Did anybody experience something like that? Any suggestions?


  • Tech Staff

    Please help us to help you. Are you using a Mac or a PC and what version of Isadora are you using?

    Best
    Michel



  • I am a mac user and I use Isadora Core 1.3.0f26...

    thanks,
    b.

  • Tech Staff

    Tested it here with version 1.3.0f32 and it works fine. One movie goes into the foreground and one into the background input of the crop actor.
    Maybe you want to try it with the 1.3.0f32 version you find it at the bottom of the page.

    Best
    Michel



  • Thanks for testing it Michel... This might be a stupid question but why does it warn me that I am about to replace my Isadora with an earlier version? I am pretty sure mine is 1.3.0f26 and the the link you sent is 1.3.0f32...

    b.

  • Tech Staff

    Ignore the warning. It did also show to me when installing.

    Best
    Michel



  • Thanks Michel... Before I had a chance to test my initial problem I discovered that the new version distorted all the jpeg images I was using with a picture player when connected to a video mixer.

    b.


  • Oh, preferences didn't hold the output resolution like it was set... Working on it...



  • Hmm, didn't help... Video mixer still a major problem now...



  • Duh, YUV mode solved it... Sorry, back to business... :)) Thanks again Michel. I will confirm the crop actor problem solved later when I am back to my rehearsal set-up in the theater...

    cheers,
    bozzy


  • Wow, this upgrade didn't do good for me... I am having all kind of problems with .png files not being transparent anymore, the video mixer distorting the images with .jpg files...


  • Tech Staff

    Tried .png file with transparency, it is working fine. Do your jpg files have different resolutions? What are you resolution settings in Isadora preferences, if you are updating Isadora you have to set all the preferences new.

    Can you send me your patch or a screenshot?

    Best
    Michel



  • Thanks Michel:

    First of all I will test the MIDI slider tonight and let you know if upgrading helped or not.
    Other stuff: 
    Screenshot 1: When I trigger 'a' the picture player should send a png file on top of the jpg but it doesn't come up transparent or it doesn't come at all.
    Screenshot 2: There is a png and a video running behind giving that cheesy window effect. If I enable YUV png is not being transparent anymore and scrambles the video behind
    And in general when I do not enable YUV two simple picture players connected to a video mixer and then to a projector do not stream the output without distorting the image.
    My resolution for now is 854 X 480...
    Thanks for all your help and time!
    cheers,
    bozzy

    23b911-screenshot1.png bb4439-screenshot2.png


  • Tech Staff

    first I would enable "keep aspect" in the projector actor. I would say the video mixer actor does have a bug, but you can get around that using two projectors and using an absolute value actor going into the intensity inputs of the two projectors, on the bottom one you have to swap the scale min and scale max of the intensity settings so it reacts oposite of its input. And you have to define the min an max scale value of the "Absolute value" to 0 and 100.

    You are right, in YUV mode the png file is not transparent anymore. But in none YUV mode it is transperent.

    Best
    Michel
    57fe5f-video-mixer.png 040ccc-videomixer.izz



  • Thank you for the patch idea... I will definitely replace my video mixer with that when I am in trouble. Maybe then I don't have to be in YUV mode and pngs won't be a problem anymore.

    On the other hand I don't think upgrading solved the problem of the crop actor... You will see the screenshots attached, they are both from the same scene. If the second stream of the crop actor is running underneath it still jumps in and out in weird triangular shapes. I will try to "keep aspect" in the projector meanwhile maybe it will help. 
    Thanks a gain a bunch Michel!!!
    cheers,
    bozzy

    ad46b2-screenshota.png 0f48b4-screenshotb.png



  • Dear Bozzy,

    Regarding YUV: YUV has no transparency information. If you turn on YUV mode, any alpha channel information with the picture will be lost. If you want to keep your transparency, then don't use YUV.
    Also, I would try a TIFF instead of a PNG to see if that makes any difference.
    Finally, is the resolution of every picture and every video 854 x 480? If you will send me your patch at mark [atta] troikatronix [dotta] com I will investigate.
    Best Wishes,
    Mark


  • Dear Mark,

    Unfortunately the resolutions I use are all over the place. Only my default resolution is 854 x 480 and I am on "scale to smallest image" mode.
    cheers,
    bozzy


  • Ummm... then it will be difficult for me to reproduce the problem, because it could be related to the various resolutions. If you want me to look into this, please find a scene where the problem exists, and list the resolution of each Movie or Picture. If you give me that, I'll recreate these and see what I can find out.

    That being said, I brought some pictures into your patches.
    Scene 1.1 in DistractedProjector.izz works as expected -- no flickering of any kind.
    Scene 4 of DistractedTVs.izz also seems fine. The Crop works as expected.
    I was also running both patches at the same time (as seems to be the case in your original post) and this showed no negative effects.
    However, there was a bug at one point where a movie playing at slower than normal speed would flicker when played above another image that was changing less frequently. This might explain the problem with DistractedTVs.izz, as it most definitely creates this very situation. However, I tested in 1.3.0f26 and saw no problems.
    I would suggest at this point that you move to the latest pre-release (1.3.0f32 at the time of this writing) -- bugs in the 1.3.0f26 pre-release have for sure been fixed. See http://troikatronix.com/download/isadora-pre-releases/
    Best Wishes,
    Mark


  • Let me look at the first two scenes I am having trouble with... One of the scenes: video1 is 720 X 480 and video2 is 488 X 348. A second one: video1 is 480 X 344 and video2 is 640 X 360.

    cheers,
    bozzy


  • Which scenes in which file? The ones I mentioned above? Distracted Projector/Scene 1.1 has a movie and a picture, not a movie and a movie.

    Best Wishes,
    Mark

Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.