[ANSWERED] Systematic "Syntax error" when importing Shader in GLSL Shader Actor


  • Hello shader lovers,

    I try to import a few shadder from shadertoy to the GLSL Shader actor and I always have a "Syntax error" that does not allow me to compile and continue.

    For this shader:, its this line that gives Isadora a problem:    N = mix(vec3(0.0, 1.0, 0.0), N, 1.0 / (dist * dist * 0.01 + 1.0));

    For this shader, its this one: vec3 getPixel(in vec2 coord, float time) { 

    For this one, its : vec3 colour = vec3(pow(abs(c), 8.0));

    So its seems to be linked to vec3 (vector 3?) but why those line and not the other with this vec3? mystery...

    any idea ?

    best creative year to all of you!

    thomas

  • Tech Staff

    @tease


    I just tried it with all 3 links, and I was able to cut/paste and run the GLSL code without issue.

    Perhaps you are missing a closing bracket or something similar when you are doing this. 
    One thing that helps me ensure I am getting the entire glsl code, is to use Cut rather than Copy, this way I can see if I left anything behind.

  • Beta Platinum

    Same here, but damm what is that GLSL code editor buggy on Windows.. Going to send a few tickets for that one, get constant freeze here with Izzy 3.0.6..

    I cleaned up the code, and it all seemed fine. Care to share the code that you tried ?

  • Tech Staff

    @juriaan

    Really, I had no issues at all (did my test on Windows).
    Please submit support tickets with details, and I will look further into it.

  • Tech Staff

    @juriaan

    Does this still happen if you update to 3.0.7?

    Best Michel

  • Beta Platinum

    Hi there both, 
    Ticket has been logged with id #4561383

    Thanks !