assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

Feature request: a pause function



  • Hey there,

    in my work I often have the problem, that during theatre rehearsals or shows, I have to pause movies and sounds and exactly resume playback at the last position. I know that I can pause the Isadora engine with a shortcut, but during a show, I don't want to pause the whole engine using a three-key-shortcut. I tried to grab the current position of a movie to use this value for determining the new start position when resuming playback, but it doesn't work, because when I stop playing back the movie, the position outlet sends a zero value. So I'm searching for a solution that allows me to run shows entirely with the lovely cuesheet-function of izzy and without having to pause the whole playback engine. 
    BTW, the same problem exists in Ableton Live, you can pause clips and resume them, but only with a shortcut, skipping or jumping to a specific position is also rather unelegant, which makes it a great program for shows, but in rehearsals, it's worse than a simple CD player..
    Best,
    Daniel


  • If you just turn the speed of playback to 0 the movie will pause but remain in the same position. If you just hook a control panel toggle up to your movie players that switches between a value of 0 and 1 you can just pause everything in tech and the resume as needed.


  • Tech Staff

    ^ The above is what I do. Using the trigger value (with a value of 0) and another one (with a value of 1) normally on the "<" and ">" keys.

    Create a user actor for it and then it will save a lot of time in the future.


  • Strange... Setting playback speed to 0 or 1 was the first thing I tried, but when I did, the playback starts at position 0 again... Maybe this is because I still use 1.3 f24?



  • Dear Lemond,

    It must be something else – I just tried toggling the speed in 1.3.0f24 and it works as expected. Are you sure you weren't accidentally connected to the 'position' input?
    Best Wishes,
    Mark

  • Tech Staff

    @Lemond
    are you on windows? Maybe using a windows codec, rather than Quicktime?



  • My bad... I forgot to tell I was using sound players! With movie players, everything works as expected. I converted the aiffs to movs, because the sound players would always skip a couple of audio samples when jumping from one scene to another. I am on a mac and 10.8.3.. Tried the pre-release yesterday and that solved many anomalies. Thanks again to Mark!

    Best,
    D.