assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

Baking object in Cinema 4D only seems to be working with FBX and not 3DS files. Is there a workaround?



  • I know this is kind of a Cinema 4D question, but it concerns Isadora too.  I followed the process for baking an object in Cinema 4D with all the differently-textured parts wrapped in a null object.  Then I tried to export that object as a .3ds, (made sure texture and object were exported to the same folder).  However, when I tried to load it into Isadora, I got the message "Texture file could not be associated" with my object.  I later realized that C4D's baking process really only works with fbx.  Since fbx is not supported by Isadora, I'm unsure how best to bake my complexly-textured object as a 3ds.  It would really help if anyone who works with C4D could weigh in and let me know how you approach this issue.  I can't really switch 3D softwares at this point in the process, but C4D's baking/export process isn't playing well with Izzy.


  • Beta Platinum

    @rollinlikethunda said:

    only works with fbx

     Hi,

    There are lots of issues to resolve when working with 3D mesh production and getting it into Isadora.

    You might consider trying a file exchange process...

    I ran a quick test to covert an fbx file to 3ds and managed to get the job done using the intermediary software Cheetah 3D. I started out looking at MeshLab as it is a free software but it does not appear to read fbx files, but Cheetah 3D does (Mac only). If you are on PC you could try the file exchange process using Blender. The fbx file I downloaded to run the test is from here. As the poly count was too high for the 3ds format I had to do a quick decimation of the mesh elements using the 'simplify' tool in Cheetah 3D. I then saved the mesh group as a 3ds file format and it has imported into Isadora. There was no texture warning dialog, and there appears to be the associated textures.



  • @bonemap Thank you so much Russell!  sorry for the late reply!  I downloaded Cheetah 3D, it seems like it wouldn't allow me to convert the file without the paid version.  It may be some other reason that it didn't work, though-- not sure.  Now that I'm aware mesh converters exist, I've been experimenting with a few.  I'd like to report that it seems my issue was due to the file name being too long, which was causing the error message despite my textures being saved in the same folder.  The Izzy documentation mentions this in an article, so I was glad to have seen that, and found the source of this issue.  Now I'm using short names and having no issues with 3DS files.  I so appreciate your thorough and thoughtful answers, as they helped me get to the root of this, and other problems.  Thanks again! You're awesome:)


  • Beta Platinum

    @rollinlikethunda said:

    the file name being too long

     Ah, OK thanks for pointing that out. I have had the same issues when using Blender to create 3ds files. Keeping associated file names short has become a habit for me. Although, I don’t have that problem with other 3D modelling software, like Cheetah 3D. Because of this I don’t know if it is a bug in Isadora, or in the way some 3D software writes to the 3ds file.

    Best Wishes

    Russell