• Hi,

    this is something that happened to me before in PureData, a given actor is behaving in an abnormal way. In PD same as in Isadora, this is solved by just replacing the "corrupted" actor by a new one having the same settings.

    However, it is quite annoying and it can become a nightmare when trying to debug something that apparently is perfectly fine.

    Resetting the actor also works and is usually preferable to replacing it, since you do not have to reconnect wires, but still need to set all parameters as required.
    Is this something known or is it only me experiencing this?
    It has happened with some other actors, but I have one patch where it happens particularly often to the "Movie player". Unfortunately I was not able to reproduce it. Maybe some weird programming also plays a role. I have the feeling that it happens when fumbling around. What happens in this case is that the player stays at the last frame when loading a new file and (as I have loop set to off) it just stays there, showing the last frame. This particular issue might be solved in the actor, but a kind of general solution could possibly be a feature allowing to "reset" a whole patch keeping user changed parameters intact. Such a reset could also be done everytime you load a patch, since in my case, closing and loading the patch again does NOT solve the issue.

    Hope this helps to improve Izzy

  • Tech Staff

    @gaspar

    Steps you can take to help us pinpoint your issue:

    • Send us your patch in a support ticket (link in my signature) so we can dissect it and let you know if, in your words, "weird programming also plays a role"
    • Tell us what Scene has the misbehaving actor (maybe label it with a Comment actor)
    • Give detailed repro steps that cause the issue to happen consistently
    • If possible, record a short gif of the misbehaving actor: https://recordit.co/

    Best wishes,

    Woland


  • I can confirm this happening on rare occasions. I have had it maybe 10 times over 10 years in various forms. Actor just locks up. 

    The trick is to catch it, that's why I never reported it. You have to reset/replace to realise that it is the fix, and then it's too late to report it. 

    Its very elusive and probably a composite of circumstances rather than a single bug. It could be file system related, as you say yourself, its happened in other softwares.

    I will also keep an eye on trying to catch it.