assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

migrating izzy v2 project to izzy v3



  • Hi there


    I am trying to open an izzy v2 project in v3, and the program crushes immediately. I was using in this project a lot of cpu based actors, so I added also a lot of gpu/cpu/gpu converters, and thought that could be the problem, so I deleted all these instances, leaving no gpu/cpu/gpu converters in the project. Still it crushes immediately. 


    What can I do to bring this project to v3?



  • Hi

    This is what I would do: In the output menu, pause the output. Then open your project, if that works you should be able to turn the output back on while in different scenes to see which ones crash. From there you can turn things off and change all available cpu actors to gpu. ...etc until you find the problem.

    So turn off output, open, change things, turn output back on, crash, repeat. You should be able to narrow it down pretty fast.



  • It sounds pretty straight forward, but in practice it seems to be much more than that. When I pause the engine before opening the project, it allows me to actually open the project. That is working.

    I have no scenes. I have no deprecated actors. I have no CPU based actors. So none of these things should be a problem. but

    Look at the screenshots. I am sending video in watcher to a scaler, and there is nothing coming out of the scaler. (01)

    If I skip the scaler and connect to the next actor, a contrast actor, there is nothing coming out of this actor now. (02)

    if I delete this video in watcher and create a new one, then it starts working


    The problem with this, is that it is happening many times, for different actors. If you are working on a big heavy project, with loads of things, it seems that I have to delete and recreate lots of actors in order to make it run. The same is happening for example with the multimix.

    Someboy else experienced this while migrating?



  • screenshots



  • @camilozk sounds weird. I would upload the patch here and let the @Global-Moderators comment



  • @camilozk Have you tried deleting your preferences?

    Cheers,

    Hugh


  • Tech Staff

    Create a support ticket using the link in my signature. We can try to reproduce the crash in the latest beta. If it crashes in 3.0.7 and not in the beta we can just give you access to the beta.