• My school is having a uge zoom meeting tomorrow evening (300+). The plan is to show a slideshow with a count down, while I address the participants into different breakout rooms.
    My problem: I can share the Isadora screen with slideshow and count down, but as soon as I change to another desktop to divide the participants into differen breakout rooms, the shared Isadora screen "freezes", because it does not have focus anymore. 

    I found a workaround without using Isadora, but is there any possibility to use Isadora "in the background", while I am working on another desktop?
    Is there any hope?

  • Beta Platinum

    Can you not use the Browser - Zoom and the Application of zoom ? So Zoom application for everything regarding your presentation and the browser window for admin ?

  • Tech Staff

    @tomthebom

    could it be that you have got app nap activated for Isadora (I think its the default setting and has to be disabled after every update). This could cause the problem, so try this: https://www.lifewire.com/contr...

    Best Michel 


  • @juriaan


    Thanks Juriaan, I will try that... ;O)


  • @michel

    I checked it, but there is no option for Isadora. (I am on OSX 10.13.6) "If you don't see the Prevent App Nap option, it means this app isn't App Nap-aware and isn't affected by it." 


  • @tomthebom said:

    My problem: I can share the Isadora screen with slideshow and count down, but as soon as I change to another desktop to divide the participants into differen breakout rooms, the shared Isadora screen "freezes", because it does not have focus anymore. I found a workaround without using Isadora, but is there any possibility to use Isadora "in the background", while I am working on another desktop?Is there any hope?

    I just tested Isadora 3 with Zoom and it worked fine even when Isadora was not the frontmost application.

    What you didn't make in your question was this: are you attempting to share Isadora when the stage is full screen or when the stage is in Preview. I've outlined steps to use Isadora with Zoom in both scenarios.

    That said, the result on the remote computer was pretty choppy. In addition to sharing Isadora's stage, I also tried sharing the output of QuickTime Player as a separate test. In both cases, the resulting frame rate on the remote computer was about 2 or 3 fps.

    In any case, I've created a knowledge base article that explains how to share Isadora's stage on Zoom.

    Please let me know here if the KB article addresses your issue.

    Best Wishes,
    Mark


  • Hi Mark, thanks for the tutorial. Unchecking the "Floating window" in the preferences made it much easier to share Isadora with Zoom. But sharing the screen works quite well for me. My job yesterday was to send about 250 pupils into 10 different breakout rooms to meet with their teacher. A slide show and a count down were supposed to entertain them, while I was doing that. Unfortunately does Zoom pause the shared screen, when I change desktop. I guess, Zoom does not update the screen anymore. I did not find a solution to keep Isadora running in the background...


  • @tomthebom said:

    Unfortunately does Zoom pause the shared screen, when I change desktop. I guess, Zoom does not update the screen anymore. I did not find a solution to keep Isadora running in the background...

    OK, I'm sorry I missed the bit about switching desktops using Mission Control. I have just verified that this is not an Isadora problem, but a general issue with using multiple desktops. It makes sense actually: why would the operating system spend time rendering a window that is impossible for you to see?

    To prove it wasn't Isadora, I tested this with Safari open to Giphy.com. When Safari and Zoom are in the same desktop, then the gif animations are moving in the screen share. But if Safari is in a different desktop than Zoom, and the Safari desktop is hidden, the animations all freeze.

    I guess the only solution if you really want to hide Isadora is to use a second display. You can put Isadora's user interface and the full screen stage (or the preview) on the second display and share from there.

    It's a pity that Zoom does not offer Syphon or NDI as an input, because then it would be super simple to get Isadora's output into the program.

    Best Wishes,
    Mark


  • Just to add a potential super easy solution to this, virtual webcam inputs are now available in Zoom (v5+) and the new Mac NDI virtual input works a treat in my testing (with a stage outputting NDI) from Izzy.

    Hope that's of use to someone.


  • Just to second @ianpep the new NDI virtual input for mac makes Isadora NDI output available as camera input in Zoom v5+. However in my system as soon as I select the NDI video as source the load monitor in Isadora jumps from 10% to 90%. This could be an issue with a more resource intensive patch perhaps.

  • Beta Platinum

    @msanii @ianpep 

    The Zoom version that reinstates NDI virtual input for Mac OSX is as follows:

    May 24, 2020 version 5.0.4 (25694.0524) Download Type: Manual Download here: Download Center 

    • Re-enable virtual camera support Support for virtual cameras will be re-enabled for users on client version 5.0.4.  

    I can also confirm that it is load hungry coming out of Isadora using what appears to be about 30% of load resources.

    Best Wishes
    Russell