• @loulight said:

    could you do the test you were talking about Mark ?

    I will try, but since I do not have the most recent C920 causing the problem, I don't know if it will prove anything.

    Best Wishes,

  • Tech Staff

    See if something simple like Skype or Google Hangouts has issues with the camera. That'd be interesting information.

  • @woland : I've been trying on skype and the image provided by the webcam is completely fluid. I used the driver of the webcam directly, I didn't use the logitech software.

    I've been trying something else : since I can have a fluid image in vvvv, I did a test with spout, sending the image decoded in vvvv in 1280x720 into isadora. But as soon as I switch to fullscreen in isadora the framerate of the image is going real slow (while isa indicates that the fps counter remains at 30, and the load remains low). When I just look at the preview in a floating window, the image become more fluid, it's not perfect yet but real better...

    I did a reverse test : sending a live image from a webcam from isa to vvvv : no problem, both images are identical

    Have you seen this before ? I don't understand why all those bugs in receiving some live inputs in isa...

    Best regards


  • Tech Staff


    Are you by chance on a laptop with an onboard Intel video card?
    I have seen cases where fullscreen video gets choppy due to the Intel video chips.
    If you haven't already, you need to set Isadora.exe to use only the dedicated graphics card.

  • Tech Staff

    If you're using a Windows laptop with an onboard Intel video card, as @DusX suggested, I'd try following the instructions in this article to set Isadora to only use the dedicated graphics card: https://support.troikatronix.com/support/solutions/articles/13000064926-windows-laptop-configuration-of-integrated-onboard-and-dedicated-graphics-cards-for-isadora-2-and-

    Do you have another Windows 10 machine on which you can test the two working C920s and the new pain-in-the-butt C920?

    C920 prices have skyrocketed during the pandemic so it's not exactly cheap for us to order a brand-new one to test this one issue (which we may not even be able to re-create).

  • @woland : I understand perfectly that it's not the right moment to buy a new C920. Indeed it's not cheap any more since the pandemic...

    I've been trying to do what you suggested @DusX , I was not sure if I had an onboard intel card. But in the list of my system components my GTX 970m is the only graphic card listed... I've tried to do the Nvidia panel configuration you suggested, but once I've choosed Isadora I can't do the next step because I don't have any drop-down menu that would allow me to choose "High-performance NVidia processor", which I think means that I really don't have any onboard intel graphic card...

  • So this conversation is interesting to me.... I have been using Logitech 920's and 930's on PC with Isadora for years without issue. They're pretty much rock solid, with OR without the Logitech software installed.

    Recently, I tried to use my 930 (which is essentially the same as the 920, but with a wider lens) in Isadora and immediately found a dramatic slowdown of the system, as described by @loulight . I wonder if something has changed in the OS in a recent update?



  • I think I've a clue about what's making the image of my new C920 not fluid : as I said earlier in vvvv I managed to have a fluid image. In vvvv I can choose between 2 differents "video format" : YUY2 and MJPG. By default it is in YUY2 and it produces the same problems of non fluid image as in isadora. But as soon as I switch to MJPG the framerate of the image reaches 30fps.

    Is it possible to do the same switch in isa ?

  • Tech Staff

    @loulight said:

    Is it possible to do the same switch in isa ?

     This is a question that I think only @mark can answer but it may be a couple of days because he's rather busy at the moment

  • Izzy Guru

    I too have a C920. But I did remove the LogiCapture software. Sometimes Isadora did not see the camera at all if I had opened the LogiCapture software at all that day. A restart fixed that. 

    But for me once it works it was fine. Maybe remove the LogiCapture software and see? Not sure how else I can help here really. Sorry.