assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

erratic sound using Isadora with Spotify



  • Hi, recently i've built a patch using izzy 3.0.7 with sound frequency bands and sound frequency watcher triggering movies, using Spotify with Loopback 2.0.0 (latest version is 2.1.4) as sound input.

    If i start Spotify and then Isadora, audio starts jumping erratically (skips forwards/backwards a few times a second) as soon as i load the izzy patch... if i start Isadora, then Spotify, usually loads the patch ok

    Should i try updating Loopback or is this a bug with Isadora?

    Mr J

      



  • @mr_j

    Hi, 

    I have done the same test but with Sound Siphon instead of Loopback and the audio played well and the frequency analysis was correct. I hope it helps.
    Best.

    Javi


  • Tech Staff

    I tried to start things in different orders on Mojave with the demo version of Loopback and Sound Siphon with different audio sources and here are my results.


    Using Loopback

    Isadora + Start Live Capture at -6db > Spotify : Fine

    Spotify > Isadora + Start Live Capture at -6db: Slight audio dropout for a fraction of a second

    Isadora + Start Live Capture at -6db > Youtube : Fine

    Youtube >  Isadora + Start Live Capture at -6db: Slight audio dropout for a fraction of a second


    Using Sound Siphon

    Isadora + Start Live Capture at -6db > Spotify : Fine

    Spotify > Isadora + Start Live Capture at -6db: Fine

    Isadora + Start Live Capture at -6db > Youtube : Fine

    Youtube >  Isadora + Start Live Capture at -6db: Fine


    So judging by cross-testing using two different audio sources (Google Chrome and Spotify) and two different virtual audio routing softwares (Loopback and Sound Siphon) and getting the same momentary audio dropout if I was playing audio through Loopback before I launched Isadora I'd say you should just launch Isadora first if you want to use Loopback. My guess is it's something to do with Isadora starting up and getting its mitts into the audio system and that during this initialization process, Isadora doesn't get along as well with Loopback (which has a brief audio glitch) as it does with Sound Siphon (no issue whatsoever). It looks like if you are using Loopback, if you don't let Isadora establish itself in the audio system before you start trying to use it for live audio capture with Loopback the tiny interruption unavoidable.


Log in to reply