assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

[ANSWERED] How to Perform Crossfades with the NDI Watcher Actor



  • hello, we try to fade in a ndi feed from resolume and also from arkaos,

    the feed is shown, in izzy with ndi watcher and projector on stage 1.

    every thing is fine, but if we fade in any way in one of the mediaservers, it switch the ndi feed in or out at something around 0,7 % of fade in or out.

    so we try to send a shader on stage 1, send it out with ndi from the stage setup and then receive it with ndi watcher , 

    in this case we can do a little fade from 0 to 0,7 of with the intensity of the projector in izzy. in and out.

    but it looks like a 5step resolutionblend or something like that.

    also if we monitoring the blend(try) in a monitor in the control panel of izzy, with a linked control id,

    we see a random flicker in the monitor all the time receiving a ndi stream.

    aslo when we do no fading action.

    so any possibilitys for us to show a fade in and out from a ndi source in isadora?

    by the way, the other way works great, we can receive the ndi from isadora in all other applications with ndi in, without problems.

    aslo ndi monitor, shows the fades which izzy do not show, at the same time as a fade.

    thx

    r.h.



  • ...... also capture.se 2020, as a virtualizier, can't show the fades we try, on a ndi mediafeed.

    so they have maybe the same problem or needs to prevent a fade on incoming ndi feeds?

    r.h.


  • Tech Staff

    Perhaps I don't fully understand, but couldn't you just do the fading you need to do within Isadora with a Video Fader or the intensity of a Projector actor? 

    If you need to control the fade from the other software, can you use OSC sent from the other software to control Isadora?



  • hello.

    the ndi feed we get is from a computer of a vj which have to send the feed to izzy. he can use resolume, isadora or obs or arkaos to send us a ndi feed over network(local). 

    in izzy patch, the video flow should be established at every moment, and if the ndi feed fades in it should also fade in isadora.

    so simple, isn't it?

    if we feed any ndi stream from or to any of that mediaservers, all show the fade from outside embedded in the ndi feed, expect isadora and capture 2020.

    this both have the same behavior.

    maybe you handle the alpha channel in a other way then others do?

    it is definitive too much work, not to use the incoming feed to show all content including fades in intensity.

    thx.

    r.h.


  • Tech Staff

    @deflost

    I don't know Resolume or Arkaos at all, could you please send me a simple Resolume file that sends NDI and fades the NDI feed in and out so that I can replicate the issue and log it?

    You may be right about Isadora handling the alpha channel in a different way, and once we have a way to reproduce that in hand I can log it as a bug and give it to Mark to update how Isadora handles incoming NDI feeds.

    I suspect that I just need the equivalent of what I've built below in Isadora, but created in Resolume (something that's sending frames and changing the fade of the NDI feed it is sending out):



  • To fade NDI in Isadora, I change scenes.

    Scene 1: NDI receiver connected to a projector, which is at 0% intensity. Fade time 3 (or whatever)

    Scene 2: NDI receiver connected to a projector, which is at 100% intensity. Fade time 3 (or whatever)

    Scene 3: NDI receiver connected to a projector, which is at 0% intensity. Fade time 3 (or whatever)

    As you fade between the scenes, the NDI feed fades in and then out again. 

    I do it this way because you need to have the NDI connection established prior to coming into the scene, if you want it to fade in. Having connected to a projector at 0% when you're not using it also allows you to see that it's working (green connector).

    Hope this helps!

    Cheers,

    Hugh



  • thx, but horrible workaround.

    you can replicate the behavior by give out the fading projector on a stage in izzy with ndi output. then open an ndi watcher connect its gpu out to control id1 and open a monitor in controlpanel of izzy with this id, there is the exact the same behaivior as if you feed in ndi from other apps.

    r.h.



  • @deflost said:

    thx, but horrible workaround.

    Because the NDI actor is it's own actor and not part of the Isadora main program itself, it does not automatically "lock on" to an NDI input and hold it for as long as the program is open like, for example, the Live Capture Settings does with a webcam.

    However, the attached Isadora patch would seem to address your issue.

    It uses a secondary scene ("NDI Input") to ensure the NDI input is received continuously. This secondary scene routes the NDI video to an Isadora "virtual stage" as defined in the Stage Setup editor.

    Then, in the remaining Scenes of the "show", you use the "Get Stage Image" actor to acquire the NDI image rendered to the virtual stage by the secondary scene.

    By using this setup, you have a continuous connection to the NDI input and can fade it in and out as you like.

    To use this patch:

    1) Go to "NDI Input" and change the 'ndi source' in the NDI Watcher actor to your NDI source.
    2) Click back to the scene "Init"
    3) Press letter 'a' to activate the secondary scene and jump to the first scene of this example show, called "Scene 1"
    4) Press the space bar to go through the remaining cues. You see the NDI image in Scene 1, it will fade out for Scene 2, and fade back in for Scene 3.

    This "virtual stage" technique is very light and should add very little in the way of "LOAD" to your patch.

    Note that the size of the virtual stage is 1920x1080 in this patch. You'd want to customize that size to match the resolution of your NDI feed if you decide to use this technique.

    Hopefully this "secondary scene" technique – which is incredibly useful in so many circumstances – will satisfy your requirements. Let me know what you think.

    ndi-background-scene.izz

    Best Wishes,
    Mark



  • @mark

    thank you very much for your explanation.

    we give it a try.

    cool, what amount of time you spend on our problem.

    thx.

    r.h.



  • @deflost said:

    cool, what amount of time you spend on our problem.

    We want you to make incredible artworks and performances. We're here to help you make that happen.

    Best Wishes,
    Mark


Log in to reply