assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

[ANSWERED] How Do I Layer Transparent PNG Files using Secondary Scenes?



  • So I am running 2.6.1 on a PC

    So I am having an issue I can’t figure out.  We are using a video to loop for many scenes with small little things on top of it, png files.  I get a bump when I hit the go because of the video I am reloading.  So I thought.  Why not have the video be in a scene and make it active.  And let it play behind the other scenes.

     

    So here is the scene with the video and the image in the same que.

     


     

    Both projectors set to additive.  The image on top is Looks really good.

     

    Now if I split to the video and the image and make the video scene active it looks like this

     


     

     

    As you can see the image burns out.  I have not changed the actors in any way.

     

    Any ideas?  I have tried many times to change the Blend on all of the projectors to all of the combinations and that does nothing.  for fun I tried a Luminous Key in both scenes.  and that does not work.

    would love to know if there is a solution. 

    thanks Jared



  • Dear @Japorte,

    The Activate Scene actors that you're using make an assumption that the video you want to bring in is an overlay on top of other layers. Right now in 2.6.1, there isn't a way to force it to the back.

    In Isadora 3, you could use a Virtual Stage in the Stage Setup to solve this problem. But in v2.6.1 you'll need to use the Virtual Stage actor

    In the background scene, you'll want to use the 3D Projector to render the image -- but not to the stage. First, adjust the z-translate so that the image fills the stage. (For HD, it's around -1.54.). Then, set the 'destination' input to 'renderer.' Note that the 'stage/chan' input says 1 by default. Leave it that way.



    In the scene where you'll combine your PNG on top of the movie, you'll have something like this:



    The Virtual Stage actor will receives the image rendered by the 3D Projector in the background scene, since it's 'channel' input is set to '1', which matches the 'stage/chan' setting for the 3D Projector I mentioned above.

    The only other setup required is that you should make sure to set the 'horz size' and 'vert size' inputs to the correct resolution for the movie playing the background scene.

    At that point, you can set the layering as you like in the 'blend' mode of the second proje fed by the Virtual Stage actor, and you'll get the results you want.

    Using this situation does not increase overhead very much, but gives you the ultimate amount of flexibility of blending your images.

    Give it a try.

    Best Wishes,
    Mark


  • Tech Staff

    I believe you can also do it by changing the layering options in the File menu

    Example File: https://www.dropbox.com/sh/7yr1oopxvqyk63w/AAAKEG-YtOkQBbcRQoGcqJgma?dl=0



  • @Woland said:

    I believe you can also do it by changing the layering options in the File menu

     With the disadvantage being that you are activating a legacy system in Isadora, reverting back to the way Isadora v1 worked for the entire file.

    Best Wishes,
    Mark



  • So both ways do work.  And both seem to have minimal impact on the machine.

    My reason for chasing this was so a looped video would not burp each time I hit the space bar.  Currently I am reloading the video in each scene and thought that was the issue.  But this backup computer just bumps no mater how I do it.

    My real video computer can handle it without a problem.  But we have a backup for a reason and I am using it for a reason.  

    Thanks for the help I did learn some new things today.  And after this I will upgrade isadora.


Log in to reply