• Sorry, but my question is a bit of topic:
    I am trying to setup an UltraStudio Recorder 3G and try to get it recognised by my MBP 15' 2017 with High Sierra. 

    So far I have 
    -connected the UltraStudio Recorder 3G via original Thunderbolt cable to my MBP. I have light in the UltraStudio Recorder 3G.
    -downloaded and installed Blackmagic_Desktop_Video_10.9.4 (which is supposed to be compatible with High Sierra).

    The result: The famous message "NO DESKTOP VIDEO DEVICE DETECTED".
    I have checked my preferences/ "Security & Privacy" settings, but somehow there is nothing blocked or mentioned.

    I tried a different computer with Mojave and the same steps, but still no luck.
    I am quite lost with this thing. 

    Does someone have experience with the setup of this thing?  :?:


  • @tomthebom said:

    UltraStudio Recorder 3G

     I am guessing this is your cable, remember that even though thunderbolt 3 cables look exactly the same as USBC cables on the outside they are very different (and much more expensive) make sure you have a legit thunderbolt 3 cable and one that is rated to carry the power requirement of the ultrastudio.

    This may help

    https://www.bhphotovideo.com/c...

    Fred

  • Beta Platinum

    @tomthebom

    Hi Tom,

    I have a 'BM Ultrastudio Recorder 3G' with me and I have it running on MBP 2020, Mac OS 10.15.7 Catalina using HDMI input from a Sony mirrorless camera. The recorder is set to HDMI: 1920x1080p50. There is a short Thunderbolt 3 cable (30cm) running between the computer and the device and a longer HDMI (2mtr) to the camera micro HDMI socket. The video stream can be picked up by Quicktime movie recorder and in Isadora, but not both at the same time. The Isadora setting matches the 1080p 50 setting. BM Desktop Video Setup had a version 11.6.

    I also have a Thunderbolt 2 BM Ultrastudio Mini Recorder with me and that is running on a MBP 2015, OS Mojave using the Desktop Video Setup 11.5.1.

    I don't have machines with High Sierra anymore, so that is as far as I can go. 

    Best Wishes

    Russell

  • Tech Staff

    @tomthebom said:

    So far I have -connected the UltraStudio Recorder 3G via original Thunderbolt cable to my MBP. I have light in the UltraStudio Recorder 3G.-downloaded and installed Blackmagic_Desktop_Video_10.9.4 (which is supposed to be compatible with High Sierra).The result: The famous message "NO DESKTOP VIDEO DEVICE DETECTED".

     You could also try contacting Blackmagic's support and posting on/checking their forum


  • @fred Thanks for your response! I did invest into an original Apple thunderbolt 3 cable and I can tell you: when you pay, your are not in doubt anymore.But still I do not see any device in Desktop Video Setup.


  • @woland Thanks for your response. I did post in the BM forum a few days ago, but I am still waiting for anyone to respond. 


  • @bonemap Thanks Russell for your response. I have the same setup. I just can't get in contact with the device. I only get this message "NO DESKTOP VIDEO DEVICE DETECTED"...


  • @tomthebom I just checked and the issue is clear the device you are using was released much later than the version of Desktop video you are trying to use, it simply will not work unless you use a later version. The first version of Desktop video that supports the UltraStudio Recorder 3G is 11.6 - this is from the release notes

    https://www.blackmagicdesign.c...

    You will need to be running 10.14 or later to use this device.


  • @fred Thanks a lot! That did solve the problem! Thank you so much for your help!