• I've now had this happen in my patch and a patch for a friend I'm helping. We are using ZoomOSC and the screen capture actor to run a live show over zoom. We have an OSC multilistener getting values from ZoomOSC and putting them into a Set Global Values actor. But the values don't show up correctly in the Get Global Values actors in the scenes. When I add a new Get actor in the scene it gets the correct values. I've tried changing the variable name but I can't get them linked again. It will also work if I add a new Set actor. It's kind of a pain and I don't know why it happens or what to do to make sure it doesn't happen.


  • @frank522 OSC listen and global values cause me headaches as well. Try using broadcaster and listener, if possible?

  • Tech Staff

    @frank522

    Could it be that you have an empty space at the end of the name or you accidentally hit return after typing the name. To be sure to have the same name on both sides copy/paste the name from the set to the get actor and don't hit the return key.

    Best Michel

  • Tech Staff

    @frank522

    You could also try putting your Set Global Values and OSC Multilistener actors in a secondary Scene that's always active (use the Activate Scene actor) and see if that helps. 

    If that doesn't help, can I see your patch (or a pared-down version of it that demonstrates the issue)?


  • Hi all, thanks for the advice. I'm helping out a friend with this one and just realized my mistake - it's out of range so it defaults to the max value. The  Gets are going into routers so the value is capped at the number of outputs. He didn't put calculators in to subtract the base value to get within range. Not sure why it didn't work in my patch earlier, but probably user error too. Thank you all for taking the time to help! This is what happens when you are under the gun and it's late at night...