• Hi I have run into an issue with hap movies on isadora under windows, which is that if the width of the movie is not a multiple of 4, it will not play. I have run into this issue with hap decoding on some other platforms from time to time, depending on the hap implementation; wondering if this behavior is fixable?

    Demo case:

    I had a hap movie file at 2910 x 1200.  Played fine on isadora 3.0.7 on mac.  On isadora 3.0.7 on windows, only played as black video.  1920 x 1080 hap movies played fine on the same windows computer isadora installation, however.  I re-encoded the problematic files at 2908 x 1200 (2908 = 4 * 727), and they now play fine on the windows computer.

  • @dbengali can you do a quick test with HAPQ instead - I am guessing this will work. I saw this as an issue with another software some time ago. It was not an error in HAP, but something to do with that softwares implementation of the decode process.

  • Hi @fred  , just tried it.  HapQ file at 2910 x 1200 also will not play.

  • @dbengali oh, one last question, if you are on windows can you make an AVI instead? Details were slow to come back.

  • hi @fred yes, I did try that earlier (that was my first guess), and I got the same result (video did not play).  fwiw, the method I used to make into avi was ffmpeg with -vcodec copy

    my edit platform is mac, and I don't have lots of options for making avi.  I ran ffmpeg on the windows computer, though, in order to do this test.

    VLC on that same windows computer was able to play both the .mov and the .avi files at 2910 x 1200

  • Hi,

    I think the restriction to multiple of 4 image size is "by design" with hap codec.

    Some more infos here:



  • Indeed, that is the case under the hood.  However, various decoding implementations are able to get around this.  Isadora on Mac for example plays these videos just fine, as do VLC (or d3 / disguise) on Windows.  It would be great if Isadora on Windows had a way to do this as well, since it isn't always the case that a multiple of four is the correct size for certain setups (though a little bit of anamorphic scaling is a workaround)

  • Tech Staff


    We may have already fixed this in the most recent beta. Feel free to open a support ticket using the link in my signature and I can add you to the beta program so you can try it out. Certainly, it is a thing that should work.