Syphon Virtual Webcam - Incompatible with OBS v26.1 and Later


  • Dear All,

    Users who have installed OBS v26.1 or later will find that the current version of Syphon Virtual Webcam (v0.9.5) does not work as expected. For Users who have not installed OBS at all, or who have versions earlier than v26.1, Syphon Virtual Webcam will work well.

    I haven't tried it yet, but it probably will work to downgrade OBS to v25.0.7. You can download that version here. If you do that, you should still follow the instructions below.

    Syphon Virtual Webcam relies the open source driver obs-virtual-webcam. When running OBS v26.1 and later, a new built-in version of obs-virtual-webcam is installed by OBS, and this new version is incompatible with the old plugin.

    For the moment, if you want to use Syphon Virtual Webcam, you will need to do the following:

    1) In the Finder, choose Go > Go to Folder..., enter /Library/CoreMediaIO/Plug-Ins/DAL/ and hit return
    2) Delete the file obs-mac-virtualcam.plugin
    3) Run Syphon Virtual Webcam again -- it will automatically install the old plugin

    This means Syphon Virtual Webcam will work again, but it likely means that the built-in virtual web cam offered in OBS v26.1 and later will not work any longer. 

    So you'll have to make a choice between the two for the moment.

    I will be looking to fix this as soon as possible.

    Best Wishes,
    Mark


  • Dear All,

    Here is a new version of Syphon Virtual Webcam that is compatible with the OBS Virtual Camera driver now included with OBS v26.1 and later.

    syphon-virtual-webcam-v0.9.6.zip

    The team has not tested this yet, but it works for me. I will post it on the plugins page once the team verifies that it works.

    Best Wishes,
    Mark