latest driver for UltraStudio Mini Recorder from Blackmagic

  • Hello Everybody,

    Can anyone help me with this? Where can I find the latest driver for UltraStudio Mini Recorder from Blackmagic?

    It was working fine on Isadora.

    Suddendly absolutely impossible to get the live input anymore.

    Thank you for the help.


  • @kdmatos

    on the Blackmagic Website




  • thank you for the reply

    I did go indeed to the support center and tried with updates 12.0 and 11.6 (presently using 11.6)

    the video camera feed is recognised by the Blackmagic Media Express, so the mac recognises the Mini Recorder

    But the real problem is that it does not show on Isadora 3 when I start the live capture settings (even though the devices is scanned and identified). 

    Any other help ?

    Thanks in advance (I have rehearsals starting tomorrow)

  • @kdmatos

    no, Idea. Ihave the problem with the Intensity Pro that I cannot record with the capture stage to movie actor(known problem) but I can see the incoming picture. 

    It is obvious but do you choose the blackmagic in the Live capture settings and the corresponding input to your signal

    if you have the wrong input you get only a black picture

  • @kdmatos said:

     Blackmagic Media Express

     you must also close the  Blackmagic Media Express before you try to connect with Isadora or other software.

  • Hello again.

    Thanks for wanting to help.

    I'm doing everything right: choosing the proper input, turning off any other software. It remains black on Isadora.

    I'm desperate!

  • @kdmatos

    perhaps you could find a solution in others post in this forum


  • Still no solution.
    Let me write down my problem more precisely: 

    I have a problem; event though the Ultra Studio mini recorder is recognized, and the image can be seen via the media express software, it is not seen via the live capture settings in Isadora (3.0.7).
    I am on a 2019 mac book pro under Catalina and the 11.7 desktop video driver.
    is there a reason why I cannot get the image anymore? It was working fine until now with the 10.5 version. It has suddenly stopped working.
    Is the driver ok? is there a problem with the video in watcher in Isadora? Etc?
    Thank you very much in advance for any possible help.
    Jean-Marc Matos

  • @kdmatos

    The only thing I can see is to try with an older BM driver again. I use the version 11.4.1 and it works but with an intensity Pro card and not with the Ultra Studio mini Recorder. I haven't one so I cannot try. Perhaps will tomorrow (Monday) somebody with one have a solution.



  • Tech Staff

    So a few things that you can try; normally this is where you sent in a Technical support question in for (and yes, it is weekend so don't expect that the Staff are on-call currently)

    - Install the 10.5 version of the driver, is that driver was working before with Izzy then that means that we at least have a setup that was working before. From there, since you still can't get any image;

    1. Verify that you get a signal through the Blackmagic software
    2. Close down this software / verify that the software is closed
    3. Startup Isadora
    4. Set up your Live Capture settings
    5. Start Live Capture
    6. No image? Shutdown Isadora and try to delete Izzy preferences(https://support.troikatronix.c...)
    7. Restart Isadora
    8. Verify or you still don't get an image (You have to redo your preferences, setup a Live Capture / etc)

    Let us know

  • Beta Platinum



    I have just tested my equipment as it is a close match to what you have described. 

    I am using a Sony A7rII DSLR with micro hdmi out to full-size hdmi input to a BM Ultrastudio Mini Recorder. 

    The Mini Recorder is Thunderbot 2 and the Mac Book Pro 16" is thunderbolt 3 so I am using  2mtr thunderbolt 2 cable with an Apple thunderbolt 3 to thunderbolt 2 adaptor (I tried it with a USBC style to Mini Display Port adaptor but it did not power the Mini Recorder and did not work). 

    I am running Catalina 10.15.7, I just installed the latest Desktop Video driver (12) from the Black Magic support site and installed. 

    The Sony A7rII is set to PAL, MP4, 1920 x 1080 25p 16M. 

    The BM desktop video setup is set to HDMI. 

    Isadora Live Capture Settings is set to Driver: Blackmagic, Device: UltraStudio Mini Recorder, input: 1080i50, Resolution: Native. 

    It is working for me. I hope you find a solution.

    best wishes


  • Izzy Guru


    I will check this evening with my BM MiniRecorder.

    Best Michel

  • Izzy Guru


    Just checked with my MacBook Pro 16" 2019, Catalina. Used a TB3 to TB2 Adapter from Apple, connected the TB2 cable with the Mini Recorder and connected it with my Sony a7s. Worked fine in Isadora 3.0.6. Had the Blackmagic driver version 11.5.1 first (worked) and then updated to version 12 (worked as well).

    What the output resolution set in your camera and what's the "input" resolution set in Isadora's Live capture settings?

    Best Michel