[ANSWERED] How to use SCREEN CAPTURE ALPHA


  • SCREEN CAPTURE ALPHA issues     I have been this the actor on an a 2012 with Catalina and it is sort of OK.  I loaded Isadora on a 2014 miniMac and I cannot get the Screen Capture window list to let me land on "Zoom Meeting --- ZoomOSC".   (it only took me three hours before I stretched out the window to learn I was trouble shooting the wrong issues and was just on the local Zoom Meeting).   I have uninstalled every program involved and started a new Mac user but this issue persists.......?


  • @joshqcc said:

    I loaded Isadora on a 2014 miniMac and I cannot get the Screen Capture window list to let me land on "Zoom Meeting --- ZoomOSC"

    I cannot test on Catalina at this very second, but in Mojave it works as expected. Also, many users are using this plugin, so I suspect there might be something else going on.

    Some questions:

    1) Do you have v0.9.8 of the plugin? If not, please download that version and try again.

    2) Have you read the part of the "READ ME" document that labeled "SPECIAL INSTRUCTIONS FOR MACOS MOJAVE AND LATER" ? Please go check that Isadora is included in those apps allowed to record the screen as described in this Apple document.

    3) What if, instead of using the 'window list' input, you type zoom meeting into the 'window name' input. Please start with a fresh copy of the actor when you try this.

    Best Wishes,
    Mark

    --------

    SPECIAL INSTRUCTIONS FOR MACOS MOJAVE AND LATER 

    On recent versions of macOS, the first time you attempt to use the Screen Capture plugin you will be presented with a dialog that says:

    Isadora would like to record this computer's screen. 

    Grant access to this application in Security and Privacy preferences, located in the System Preferences.

    When you see this dialog, do the following:

    1) Click the "Open System Preferences" button. You will be taken to the Screen Recording item in the Privacy tab.
    2) Click the checkbox next to Isadora icon to enable the Screen Capture plugin.
    3) Restart Isadora. The Screen Capture actor will now be enabled.


  • @mark

    I can confirm, it's working as expected on Catalina. With one exeption, though. If 'Use dual monitors' is selected in the General Zoom Settings, there is a second window showing up (Only showing the shared content without any options or other participants). This Window is not listed in the SCA window List.

    Edit: I have to correct myself, it is listed and showing after reapplying the SCA actor.


  • @dillthekraut said:

    I can confirm, it's working as expected on Catalina.

    Thanks so much for letting us know. Let's see what @JoshQCC has to say once he looks at my suggestions.

    Best Wishes,
    Mark


  • @mark.   Thanks, I can get back to that machine after Saturday.   That screen capture works for all my other windows, but it won't let me select the Zoom Meeting for ZoomOSC.   I did try to type into window list, but it redid it to the regular zoom meeting.   I'll try again this weekend, it is just so weird.


  • @joshqcc said:

    Thanks, I can get back to that machine after Saturday.   That screen capture works for all my other windows, but it won't let me select the Zoom Meeting for ZoomOSC.   I did try to type into window list, but it redid it to the regular zoom meeting.   I'll try again this weekend, it is just so weird.

    Since you don't mention it above, I want to emphasize #3 in my suggestion list: What if, instead of using the 'window list' input, you type zoom meeting into the 'window name' input. Please start with a fresh copy of the actor when you try this.

    Best Wishes.
    Mark