Audio playing even when movie player visibility is off



  • Not sure if these two things are related, but I have received multiple crashes from my latest show; I have the error log, but it's too long to post...

    Aside from crashes, in a few scenes I have multiple movie players (audio only, not connected to a projector) that the visibility is set to "off" on entering the scene, yet audio from those players is still outputting. The movie player actors themselves look normal, and show no sign of playing. The audio will continue to play even when clicking to another scene. The audio will only stop when I have closed Isadora.

    I am unable to consistently recreate this issue. It happened during preshow tonight, and continued to act screwy after multiple restarts of Isadora and reboots of the computer, so we just started the show in the scene after preshow. But tonight after the show, I've had difficulty recreating the problem. It seems to happen only in scenes with multiple movie players, most of which should not be visible upon entering the scene. It seems to maybe happen with mp4 files, although I'm not sure if it's exclusive to that.

    I have also attached a screen shot of the main offending scene, just in case I am just doing something really obvious and stupid.

    Thanks!

    Doug 069edb-screen-shot-2013-07-23-at-11.44.00-pm.png



  • Dear Doug,

    What version (exactly) of Isadora are you using? If you are using 1.3.0f24 then try upgrading to the latest pre-release at http://troikatronix.com/download/isadora-pre-releases/ to see if it alleviates the audio file problem. There is a bug in the pre-loading code when the 'visible' input is off for audio-only movies.
    If you want to stay in 1.3.0f24, then I would do the following to accomplish what I see in your patch:
    1) Set the 'visible' input 'on'
    2) Click on 'speed' and tick the "Initialize" box, setting the initial speed to 0
    3) Use the 'loop end' trigger to trigger a Trigger Value actor, which sends 1.0 to the next 'speed' input to start that clip playing.
    But also, I have to ask: instead of having all these Movie Players, why not just edit the 10 sounds into one file? It seems you're just playing one after the other, thus they could simply be in one file, which would also
    Best Wishes,
    Mark

  • Tech Staff

    There have been some well known problems with playing audio, so first we will need your Isadora version number and system specs (mac/pc etc..)
    Also, MP4 may be a problem, if you are playing straight audio I would suggest a Wav or aiff file (and the audio movie player actor), just to eliminate compression as a cause. If these are video files with audio, try that standard motion jpeg MOV.
    One issue I see is that although visibility is set to 0, speed is not.
    Its possible that the movie player is playing since the speed is set to normal (1), and only blocking the visible element (video stream) since the visible is set 0.
    I can't remember the exact behavior right now, and unfortunate have to run.
    Try setting the speed to 0, that would be my suggested first test.


  • Tech Staff

    Looks like Mark beat me by a moment. :)



  • Dear DusX,

    Actually, I recommend using MP3 or some other compressed format unless you really need the quick start/looping features of the Sound Player actor.
    Best Wishes,
    Mark

  • Tech Staff

    Good to know..
    I suggested those formats because I just finished a project using them.. where all worked perfectly.. so they seemed like a good suggestion.
    I will try some MP3s..



  • Dear DusX,

    Yes, well part of the issue here is that 1.3.0f24 has a bug in the Sound Player that will crash Isadora sometimes when the sound stops playing. That's fixed in the pre-release, but I haven't made that official. (Waiting to do so b/c of some pending bugs you've submitted, actually... I will be getting to those as soon as I can.) The bug that knowtheater is encountering has to do with the preloading of audio only movies, which is also in 1.3.0f24 but I believe to be fixed in the current pre-release.
    But, for the record:
    1) For short sounds that require nearly instantaneous response, use WAV and AIF. Use the Sound Preload actor with the 'mode' set to 'forever' to ensure those sounds are in RAM. Then, when you trigger, it will output very quickly.
    2) Use the Sound Player if you need the crossfade loop. But again, this should really be for shorter sounds -- not for something really long. (There's nothing stopping one from using longer sounds... it's just that they get loaded into RAM [even when you don't use the Sound Preload actor.] Stereo audio is about 10 MB / minute, so a 60 min file is 600 MB. Totally possible of course, but maybe not how you want to clog up your RAM.)
    3) Otherwise, use an encoded format (MP3) that ends up in the Video Bin, and play those using the Movie Player or Sound Movie Player.
    Those would be my suggestions for 'best practices' when it comes to audio files.
    Best Wishes,
    Mark


  • Thanks for the quick response!  I'd been using 1.3.0f24, but once this problem started occurring, I updated to 1.3.1f02.  I'm using a MacPro with a quad-core Xeon running OSX 10.6. 16GB RAM.

    After doing a bit more tinkering, it seems this problem crops up when the actors are triggered to become visible, I click to another scene before the track is over, and then come back to that original scene and those actors that were triggered earlier start playing.  Using the speed control fixed the issue.  And as far as using these 10 movie players instead of just one edited track, that's just laziness on my part.  These were just placeholders, as I didn't know which tracks we'd end up using and in what order, so I just plopped them in to give the director a listen.
    Mark, I will upload the crash report when I get back into the theatre this evening.  Thanks so much for all your help, and for the very useful suggestions on the "best practices."
    Doug

Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.