• Hi Guys

    I also have a problem, I have a 3d moon set up and running, only when I go to another cue and back to it, the original texture map is showing instead of the texture I picked. And any tips on how I can get a smoother motion/rotation on the model would be much appreciated. 
    Thanks 
    Joe

  • Hi Goodboy,

    Is your texture a picture or a movie ?
    For help on the rotation please post a patch showing how you are doing it actually.
    Mehdi

  • Hi Mehdi

    It's a pic-jpeg
    Thanks
    Joe

    b30865-izzy-2013-10-11-at-09.14.17.png


  • Hi,

    I've had this problem once.
    Try to trigger shortly visible off & then on when entering in the scene.
    Mehdi

  • Yes this works, but not good for during the show :)

    Thanks Mehdi

  • Dear Goodboy + All,

    When you exit a scene, any texture map you fed into the 3DS file is discarded. Thus, if you leave a scene and come back to it, the original texture map will show unless you explicitly send new video into the 'texture' input.
    However, if your patch is using the Picture Player as shown, it should always send the picture when you enter the scene. What happens if you remove the Sprite actor? Does it work then?
    Also, what is the resolution of the picture going to the 3D Player?
    If you want me to debug this, send the .izz file, the 3DS file, and the moon picture and I'll see if it's a bug. (mark [atta] troikatronix [dotta] com)
    Best Wishes,
    Mark

  • Hi all

    Just back from rehearsals (on Irish time) and really appreciate the quick response from all, Hi Mark, hope all is well in your world.
    So ok, I too am very new to 3d models and I might be skipping obvious solutions, it occurred to me that the replacing texture file I want needs to be in the same folder as the 3DS file? also it's a png not jpeg? or the result of it being a free 3d download. 
    When I remove the Sprite actor, same result.
    Resolution is ARGB 300x300   
    I have sent patch, thank you.

    Novice 3D level. :)

    Joe

  • Dear Joe,

    OK, first, when I attempt to load the 3DS file, Isadora shows a warning that the texture map file (MOONMAP2.JPG) is missing. That would be the first problem, because you won't be able to add your own texture map if the original file isn't there. (Note: I successfully changed the file name of "moon transparent.png" to "MOONMAP2.JPG" and your texture map appeared applied to the sphere. So that's one way to solve the problem immediately.)
    But, to make the test work, I created an 512x512 pixel JPG picture called MOONMAP2.JPG. Then I loaded up the 3DS image and "moon transparent.png" into the patch. 
    And, in fact, it's a bug. Upon clicking into the Scene, the PNG picture does not override the existing texture map. But, as Mehdi pointed out, turning the 'enable' input of the Picture Player off and then on, did allow it to work.
    I'll solve this bug. But in the meantime, what you can do to solve the problem is something like what is shown in the attached picture.
    To make this work, you'll need to click on the word 'mix amount' in the Video Fader, and set the 'scale max' value to 0.1\. Also ensure that the 'once' input of the Wave Generator is set to 'once'. This will basically force the image to be sent more than once, and will ensure the texture map will be applied to the 3D model.
    Best Wishes,
    Mark

    edbf5f-3ds-texture-map-workaround.png


  • Thanks Mark

    Yes, thats works!, so... is there a way to fade it in? right now it's snapping in regardless of what time I enter into the jump actor in the previous scene. 
    Also, did you have a problem mapping the texture image fully onto the model? I can't seem to get it to fully 'wrap' around the sphere. The reason I'm using Sprite is that it gives more coverage than without. I have also tried 1024x512 dimensions on the jpeg with same result. 
    Again, thank you for speedy reply.
    Joe

    8b12cc-screen-shot-isadora-3d.png


  • Dear Joe,

    If you want to fade it, you'll need to render it to the 3D Renderer which will output a video stream. Then you would display it on the stage using a normal projector, and it will fade.
    I don't know why the texture isn't wrapping around the model... that's a function of the model and what the original texture map looked like. You should match the original if at all possible, in terms of its dimensions and what the image inside looks like. Otherwise it is likely not to wrap properly.
    Best Wishes,
    Mark

  • Great Mark, will do, Thank you so much for your help :)