assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

Frame accuracy on multiple computers



  • Well, not having done an significant experiments with this myself, I will say that several Isadora users have reported to me that if you 1) preload all the movies, and then 2) start them at the same time, that they will in fact stay in sync for quite some time.

    Matthew's method will most certainly work, but everybody should be aware that changing the speed of quicktime movies frequently introduces a fair amount of CPU usage. That's fine if all your doing is playing one movie, but if your doing lots of effects, etc., it can be somewhat problematic.
    My advice is always: try the simplest thing first. If that doesn't work, then seek a different solution.


  • Mark, Thanks for the info. I will only be using a player and a projector. No effects at all. All of the computers will have different content on them but they all need to stay in sync with each other. The video clips will be HD. Should I follow your instructions that you posted back in 2007 to set this up? Or are there newer ones out there?



  • Mark, I have found what you are reporting to be true with movie playback on a single computer but, in my experience, once you start doing this across multiple computers, all bets are off. Of course, your comment about CPU usage is completely accurate although this is slightly dependent on codec choice.


  • Tech Staff

    you can DOWNLOAD a user actor I made in 2007, in the old Forum, it does what matthewH describes. To sync among multiple computers you have to add a net broadcaster and a listener. At that time this helped me to keep movies in sync on the same computer and over network with other computers. But as Mark said, in my experience keeping movies in sync on the same computer this is not necessary anymore, Isadora really improved that since then. But it can help staying in sync on different computers.

    Best,
    Michel


  • Beta Gold

    Hi,

    I've done a lot a sync between computers, and all what I can advice is to preload the movies and then just trigger start at the same time.
    I've experienced it with very high resolution movies, and it was working very well. 
    I've even tried with different kinds of computers, playing back timecodes, and taking photos of the screen, the result was great without having any synchro.
    I've tried to synchronise, but the process was heavy, and this was making the computers out of synchro...
    For info I was running a master computer and four slave computers ( so five should not be a problem ) with movies 4096*768 pixels.


  • So there is obviously quite a divergence of opinion on this topic. At some point I should set up a test here to see if I can find some definitive answers. But as usual, my advice would be to try the simplest way first (e..g, no sync). If that doesn't work, try something more complex (e.g., Michel's actor.)



  • Thanks for all of the comments. I guess I will experiment also.



  • Bump on this! I've been able to set up pretty solid sync w/ OSC, but when running from the SAME computer to 2-3 outputs, I run into more serious drift - even when the targets FPS is reached no problemo. Any ideas on this guys?


  • Beta Gold

    @cam3LD : Would you give a bit more infos about the hardware config + how the multiscreen is set ?



  • Here is a link to program MultiScreenermade with Max/Msp: http://www.zachpoff.com/software/multiscreener/ .

    _"MultiScreener is a set of free applications that synchronize the playback of Quicktime movies on multiple computers, using a local network to tie them all together. (It can also sync multiple movies on the same computer using multiple monitors.)"_
    Tested:
    1. MacBookPro (17-inch, Early 2011) as a server with one output + MacMini Server (Mid 2010) as a client with two outputs, OSX 10.6.8\. 3 x PhotoJpeg 1280x720 (quality - medium, 25 fps, 10 min long)
    2\. Hackintosh 3.50Ghz Intel Core i7-3770K, 16 Gb Ram, Nvidia GTX 670, OSX 10.8.3\. first output: DVI to TrippleHeadToGo - AppleProRes 422 3840x720 + second output: DVI - AppleProRes 422 1280x720, (25 fps, 10 min long)
    On both configurations Multiscreener worked just fine, no visible delay. Video played as a loop about 8 hours.