assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

OSC Listener from Qlab



  • Hello,

    I'm looking to use the OSC listener actor to receive a OSC message from Qlab. The two computers are connected over a wired LAN. I've tested Qlab to Qlab with success. Can someone walk me through an appropriate patch? I've got the channel on 1, type on float, and then a trigger set to an envelope generator, which then (supposedly) should trigger the effect I'm looking for which is attached to a projector. I also have set up things for OSC in the communications section of the menu, under stream setup. Any help with a patch for this would be great. 
    Thanks,
    Alex

  • Tech Staff

    I don't know QLab very well but if QLAb is outputting OSC then open up the Communication Window in 'Communication'>'Stream setup' click auto detect and do your thing in QLab - you will see a series of numbers appear. Once done click renumber ports at the bottom. Close the window and go back to Isadora.
    Then in the OSC Listener type in the port number. 
    I also have a number of OSC tutorials on my blog.

    http://vjskulpture.wordpress.com/category/osc/



  • Dear Alex,

    You must also 1) enter the correct IP address for the target computer (Isadora), which will potentially change each time you connect your computer if you're using DHCP and 2) use port 1234, the default port number Isadora uses to receive OSC. (You can change this port number in the MIDI/Net tab of the Preferences.)
    Best Wishes,
    Mark




  • Checked the Isadora manual and sent a message internally (no router) from Qlab with the OSC destination being localhost : 5300. The message was a custom message with the address /isadora/1. Under Communications>Stream Setup, I set the stream setup to be Open Sound Control, and selected auto detect input, and fired the cue from qlab without success... any suggestions would be welcome.


  • Tech Staff

    Isadora's default port is 1234 (can be changed in settings)

    You need to restart Isadora if the port changes :) let us know how you get on. 


  • No success yet. Should I be seeing something when I connect auto-detect Input and fire the cue from Qlab? This is why I think my addressing might be the issue - should I fire /isadora/1 over qlab? I don't see anything happening if I leave the stream setup window down, nor when I close the drop-down menu.

    Thanks,
    Alex


  • Dear Alex,

    I got this working with the QLab demo pretty quickly. Here are some tips.
    First, you must set click on the gear icon at the bottom right of the main window to get the Workspace Settings. Here, you can set the IP address for the target computer and the as well as the port number. See the first picture for the configuration I used. (Isadora was running on the same computer, so the IP address is 'localhost' and I set the default Isadora port number of 1234.)
    Make sure that Isadora's port number is still 1234 in the Midi/Net tab of the Isadora Preferences.
    Then add an OSC Cue. You'll need to change the Message Type to "Custom" and then enter a custom message. To send the number 5.0 to OSC Listener with it's channel set to '1', I used.
    /isadora/1 5.0
    This worked perfectly.
    To send to OSC Listener on channel 2, and to send a value of 24.3, you'd set the custom message to
    /isadora/2 24.3
    Maybe these instructions will help to get you going.
    Best Wishes,
    Mark

    c93f7b-qlab-setup.png 92c88f-qlab-osc-message.png


Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.