assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

/ Can't read .Mov file created from "Start Recording Output Stage /



  • Hi,

    I'm trying to read a recorded output stage video in a .mov file without having to put it into after effects.
    When launched with VLC the file is shown as a 00:00 timestamp even if it over 600 Mo and doesn't read.
    When it's launched with Quicktime X it's converted (can sometimes take a long while) then the video is corrupted.
    It looks like a glitch art video. (which can be handy ;-) )
    I can only open it in After effects to export it to another format.
    I would like to reduce this conversion time and read the file natively.
    I had the same problem in Mountain Lion and now in mavericks, I also tried exporting with different codecs such as Photo-Jpeg, Animation, H264.
    Do I have to install a special codec on my system?
    Why do I have to quit and relaunch Izzy in order to do another record session? (otherwise the REC keeps blinking but the file isn't recorded entirely)

  • Tech Staff

    It sounds to me like the files wrapper is not completed because the record session is not ending correctly. That explains why most software is unable to open the mov, it is just lucky that After Effects seems able to 'fix' it enough to read it.
    Maybe you can do something in Isadora to force the record to stop.
    Have you tried jumping to an empty scene before selecting to stop recording?



  • Hi DusX,

    thanx for you kick reply.
    Yup I had the same impression about the wrapper.
    No I haven't tried jumping to an empty scene to stop recording.
    I'll give it a try.
    Thanx


  • Hi, I placed a new scene with a white shape.

    Quicktime was able to convert the file and show it properly.
    VLC can't read it.
    Thanx I'll keep on testing this because it will come handy to save realtime performance.


  • What codec did you use when recording the stage? Are you running on a PC or a Mac? (I'm guessing Mac because you say Quicktime X, but I wanted to check.)

    Best,
    Mark



  • Ooh. I'm bumping this discussion because I'm having the same issue recording my stage now with my Mavericks MBP on Iz2.0, but it was also happening before on older versions. I've tried a lot of codecs to save from in Isadora, especially PhotoJPEG, H264 etc but nothing seems to work. 

    The files will open in QuicktimePro7, CompressMovies(1.1), Compressor, MPEG Streamclip for me, from where they're fine, but not in QuicktimeX, GoProStudio or quicklook. Up until today I was panicking in case I lost QTpro7, but having found that other software will re-encode the files successfully I'm a bit happier.
    I can encode them again from the above software as anything else and they open, so it's not major for me, especially as I've not yet found a need to capture and reuse footage within a patch. My captured "temp" movies do the same, and won't open in Isadora, which may be a problem one day if I need to record and replay anything live.
    Has anyone else got this bug or found a reason/solution?


  • Dear All,

    I've been very consumed with continuously fixing bugs in 2.0, which means I haven't been on the forum a lot. I completely forgot about this issue.
    Would one of you who has experienced the problem be so kind as to file a formal bug report at http://troikatronix.com/support/isadora/ please?
    When you do this, it gets filed in our system, the tech staff will be in touch with you to ensure we can recreated it, etc. It is the best way to ensure something gets fixed.
    Posting bugs in the forum is also good, but if you don't get an answer about it from the forum moderators or the community, filing a bug report is the surest way to get action.
    Best,
    Mark


  • Hi I'm on it right now. There are a few problems with capture stage to disk Starting from actor help (files a proper bug report) to the fact that it doesn't work all the time. For a dance piece I'm working on this simple patch that produces a displacement on a wall paper based on another movie. I'm sending the patch. For me it works "sometimes" and sometimes it doesn't. I mean recording stage with this actor.b401d1-braises-displace.izz



  • .. going on on this problem I see that recording stage with Isadora in photojpg codec has several problems. First of all as said here the wrapper seems to be damaged because quicktime x needs to convert the file. But the thing that si mysterious (mark?) is that if I record with syphon recorder. It is just fine and the frame rate stays at 25 while recording with isadora makes the fps to 12. More tests to come and proper bug reports coming!!!!


  • Tech Staff

    @Armando experienced the same the last days



  • I believe that QuicktimeX on Mavericks is now always going to convert the file to H264 for playback with the new apple AVFoundation. Therefore the fact that it is converting the file doesn't actually mean the original format had an error, just that QKTX now 'prefers' to run playback only with AVFoundation, hence the conversion to H264. I don't think you can turn that off in preferences.... (and I need to double-check this to be 100% sure).

    Meantime, try opening the file in QKT7 Pro instead, if you have it?

    Looking forward to seeing the official bug reports coming in ;)



  • After a bit of research it does seem like the Mavericks codec or container problem at the bottom of this.

    If I set the compression codec to Hap, Hap Alpha, H.264 or ProRes4444 the stage records, and captured files can be read directly in Isadora, but as above they'll all need to be imported in QT7Pro and recompressed before they'll show up in the Finder quickview, or used by some other apps. Other codecs might work too, but after a bit of success with these ones creating files that could be converted later I didn't check them all to see if one creates a file that can be read directly by QTX or the Finder immediately. 
    I'd mistaken the Finder's difficulties for "failed" recordings, but once reprocessed these are OK. Just a pain to keep having to work on them twice.
    I wanted to confirm that a captured file from a channel could be replayed within the same patch without having to reprocess mid-show, but this seems fine.

Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.