Isadora on Maverick - No webcam



  • Hey, guys, I am running into an issue where i can not get Live Capture to show my FaceTime camera. Does anyone have the same issue. This is brand new Retina...



  • Max Msp works, so has VDMX


  • Tech Staff

    Do you have the core video upgrade? Sometimes quartz files can stop the iSight.



  • Dear All,

    This problem is raising its ugly head more and more. I am unsure at this point if it is a Maverick problem, but for sure there is a problem with the retina version of the Mac Book Pro. I don't have a good solution at the moment because I don't have a retina on which I can test this. I'll probably have to buy one.
    bareimage: private message me. I've got a special version of Isadora I want you to try on your machine that may solve the problem.
    Best Wishes,
    Mark


  • Dear All,

    Just FYI, some details from a user. Isadora is not the only software facing this problem.
    He said:
    _I can not get the following programs to capture: 1\. Isadora 2\. Pure Data Extended 3\. Modul 8 4\. Max MSP both jit.grab & jit.qt.grab work but jit.qt.grab is deprecated_
    So it would seem to be an issue of the old QT driver. Like I said, I have an internal version that may deal with this. I'll keep everyone updated.
    Best Wishes,
    Mark


  • For people to be aware, I dug deep into the issue with the webcam. The reason for the issue is that Apple choose not make QuickTime drivers for the FaceTime camera to be available. This is causing issues with applications that rely on the Quick Time framework.

    The fast workaround for this issue, if you are getting new MacBook Pro 2013 is to forward the video feed from a program that is using QTKit to Isadora over syphon framework. If I will have a time tomorrow, I will make an easy application that can do this tomorrow.
    PS Do not try to even do it over Quartz Composer, same issue. How typical of Apple to screw everyone.

  • Tech Staff

    Thanks @bareimage that maakes sense. But what a silly thing for Apple to do!



  • Skulpture: There are three ways to deal with camera in Maverick. Quicktime Framework, QTKit and now AvFoundation Framework. From what I have heard, the Quicktime framework is using 32 bit architecture. The big plus of that architecture was control over the video feed that camera produces (quality, size, etc) QTKit on the other hand has no settings to change, making it much more wasteful process. AvFoundation has re-introduced some settings back into the user hands. Until now, most programs still relied on the older method of image capture, including Quartz Composer. Now with introduction of Maverick/Retina 2013 they decided that since the Quicktime framework was old, that they can get rid of it, or at least not to support it with drivers.

    Apple always does these things, remember Shake?


  • Please forgive me if I'm missing something obvious.

    I am having a related issue, and since I don't fully understand the Syphon/ Quicktime Frameworks you are talking about I feel a little stuck.

    The Webcam is just one symptom of this issue for this show more importantly Isadora is not recognizing the two USB Capture cards I've tried either. (Elgato Video Capture or Roland VR-5 Mixer's Capture Software.)
    is this purely because they are USB Capture Cards?
    The Elgato Capture card will capture but only to record and I don't know how to "hijack" the signal in to Isadora's Input.
    The Roland software will recognize the Webcam on the computer so I'm guessing it doesn't use the QT framework (using words it don't really understand)
    The Roland Hardware will recognize the DV camera (this is the end goal) using the S-Video Cable I have plugged into it but the signal will not pass through from the Mixer to the any software on the computer.
    Any Suggestions or Feedback would be hugely appreciated. Another day of designers and director waiting on the live feed to function will be stressful but is looking likely.
    Thank you all in advance.
    G Minnes , TD, Western Canada Theatre  |  Mac Book Pro 2.3 GHz Intel Core i7 16 GB DDR3  - NVIDIA GeForce GT 750M 2048 MB 


  • GMinnes

    I do not know what Elgato card you have, but it sounds that this card is designed to work ONLY WITHIN supplied software. There are many other brands like this -BlackMagic USB capture, Elgato card I tried some years ago and I can name few more. The same may be true to Roland hardware. Also there are many cards that do not work with mac.
    I recommend to look at this list again
    http://forum.garagecube.com/viewtopic.php?f=1&t=3951&start=60
    It is somewhat outdated, but many devises that are reported to work are still on.
    However with new Apple development it will get more difficult to find working solution. And I see you end goal is to use DV camera as live input. I personally have given up this method long time ago. The quality, speed and CPU load is much better with USB devises or better yet with Matrox MXO2, BlackMagin Intensity Shuttle, AJA etc. 
    So if I need very cheap capture device I use USB dongle(the one that works on mac) with security cam or USB camera with native mac drivers(ie. driverless). Otherwise cards named above. If I must use DV input then Canopus, Dazzle Hollywood firewire cards are OK.


  • Dear All,

    For sure it is verified that on new retina Mac Book Pros, the internal web cam is no longer available in Isadora. I am working on this problem. But Vanakaru may be right that some cards may be not be able to capture except in their own software. 
    The best test is to try to capture with QuickTime Player. See instructions [on this page](http://support.apple.com/kb/PH5871), and note the line "To change the input source or quality of the recording, click the arrow button in the controller." If you find these cards can record with QuickTime Player, and not Isadora, then please send me a bug report [as outlined here](http://troikatronix.com/troikatronixforum/discussion/65/bug-reports-guidelines). 
    Best Wishes,
    Mark


  • Hi Mark, Any new developments on this?  I am lending a student a usb camera for now.

    thanks
    jamie


  • Thanks for documenting this as I am afflicted with this problem, but at least I now know I'm not alone.

    ta


  • I've been working on this for the last several days. It's just not stable/ready enough to give out. It's my top priority at the moment.

    Best Wishes,
    Mark


  • EDIT - I was just asking if there was an update to the beta/patch for this issue with Retina MBP's... and I just found a really simple external solution:

    [http://code.google.com/p/syphon-camera/](http://code.google.com/p/syphon-camera/)
    Freebie webcam syphon server. Click on 'FaceTime (Built-In)' cam, check the box 'Send to Syphon' - then use the built in 'Syphon to Video' or 'Syphon to Image' actors and select that stream = same same but different of Video In Watcher.
    Helpful if the retina/mavericks webcam issue can be patched in future releases, but this seems to work just fine in the meantime.


  • Dear All,

    If you download the 2.0 pre-release, it will solve this problem with retina Mac Book Pros and the internal camera. You can use the pre-release even if you haven't purchased the upgrade through our early adopters program -- you just won't have access to the 2.0 features.
    Best Wishes,
    Mark

Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.