Matrox TripleHead issues



  • Long time reader, first time poster.
    I just bought a new retina mpb and I'm having a terrible time getting it to talk to my Triplehead (ether of my Tripleheads).  I updated the firmware per Matrox's site, but I can only get it to see one of my external monitors.  It tells me there are three monitors attached and all is well, but I only get one.  I've messed around with the resolutions a bunch, just to see, but nothing changes it.  Has anybody had a similar problem and/or successfully use the Triplehead with the new mbps?  (The other weird thing is that sometimes -- not always -- the one monitor shows me my mac's toolbar at the top of its screen...even though I'm not mirroring.)
    Any thoughts GREATLY appreciated.
    Thanks in advance!
    Jake

  • Tech Staff

    Don't know if that helps: in the manual its written to start the machine without connecting the monitors/projectors, then connect only one, then when its recognised the next etc. For my setup that made a big difference, but I'm not on retina... Cheers, Alex


  • Tech Staff

    What model of triple heads are they?

    There are 3 http://www.matrox.com/graphics/en/products/gxm/

  • Tech Staff

    @jrhooker

    the toolbar issue on Mavericks could be this, see Skulptures TIP.

    Best
    Michel


  • Tech Staff

    Could be that actually.



  • Thanks for the tips.  That did work to get rid of the menu bar, which is excellent.

    I'm still not getting a signal out to all three of my external displays -- just the one.  I did try the fix Michel offered, but to no avail.
    @skulpture -- It's a Digital Edition.  And according to the Matrox website, all I need to do is upgrade the firmware.  That said, I'm currently using mini-DVI and haven't upgraded to Thunderbolt...will that make a difference?
    I'm going to do some switching of hardware today and see if that helps.  Any more thoughts still greatly appreciated!


  • Still trying to work on this, if anybody has anything for me.  But it looks like it might not be anything to do with Mavericks, but instead lack of compatibility between the triplehead and the Intel Iris graphic card.  If anybody knows a workaround, I'd love to hear it.  I tried SwitchResX, but to no avail, yet.  Looks like I upgraded too quickly.  Any other hardware out there that does the same thing as the Triplehead?


  • Tech Staff

    Did you try it with anything else other than the mini DVI?

    Ive forgot what i have used in the past. I have a feeling it needs the Dual Link DVI when using digital video. It might not have enough power via the mini adapter. Maybe try with VGA but the resolution will be lower.


  • @jrhooker, I would suggest the you call Matrox support.  I've always found them to be competent and helpful: I've never had an issue that they couldn't solve.  I'm on Windows, so I can't help you!

    Cheers,
    Hugh



  • I can confirm that the Digital Edition works with a rMBP although I have only tested using a model with dedicated NVidia graphics and the Monoprice mini DP to Dual Link DVI adapter


  • Tech Staff

    I am pretty sure you need to use it with a Dual Link DVI - I don't think it can handle the mini DVI adapter.



  • @jrhooker

    I just got mine working this morning (testing it to sell it!) on a brand-new MBPr

    http://cgi.ebay.ca/ws/eBayISAPI.dll?ViewItem&item=221400515027

    But what I did was this -

    Installed latest switchresX

    Used MDP -> VGA into triplehead VGA port, then three DVI-VGA adapters out.

    Set the resolution via switchresX to 2400 x 600 (Mark says that's the max rez for triple head on mbpr, maybe that meant only if you use VGA)

    (Might have done vga into VGA-DVI adapter too, instead of / in addition to VGA right into the VGA input on TH2G - can't remember and I've disassembled / repacked everything).

    Probably restarted the computer.

    Tricky to get switchresX running with the security / sandbox settings - make sure it is actually running!

    Mavericks kept telling me "unknown developer" etc.  So I had to go to security settings and there was a message there asking if I wanted to allow switchresX to run.  No other thing I did got it running, i.e. the preferences interface always said "switchresX is not running,"  Even when I told it to start it at login, it didn't start nor did it warn me except in the SwitchresX control panel.

    Have never used it with DVI, I'm pretty sure you can't mix DVI and VGA signals, it's all one or the other - i.e. VGA in, all VGA out, or DVI in, all-dvi out.  Not 100% sure but kinda sure.


Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.