ETC Element, Midi Show Control

  • Hey everybody,

    I'm working on a show and we'd like to use midi show control from an ETC Element light board to trigger stuff in Isadora using the Midi Show Control Watcher. For some reason, it seems like the Midi Show Control Watcher isn't parsing the Midi that's coming form the Element. I know that Isadora is seeing the midi data, because it's showing up in the Monitor window, but the Midi Show Control actor doesn't show any changes.
    Has anybody used the Midi Show Control coming from an ETC board? I'm kind of drawing a blank about how to troubleshoot this. I'm attaching a screenshot of the midi monitor and the show control watcher, let me know if there's any other information that would help you help me.

    f89c41-screen-shot-2014-06-06-at-6.33.46-pm.png 07b7fa-screen-shot-2014-06-06-at-6.34.52-pm.png

  • Hi Daniel,
    Perhaps you have done this already, but... have you set the MIDI input port in the Menu bar>Communications>MIDI set up?
    Use the drop-down menus to choose a port for the connected MIDI device and the incoming MIDI data will then be routed to that port only, so if you choose Port 1, and then set the MIDI port parameter on the MIDI Show Control Watcher to Port 1 as well, it will limit it to watching MIDI from that device.
    The otehr three input parameters on the actor also need to be set to match the MIDI messages. IF you cmd-click (ctrl-click on windows) on the name of each parameter it will give you the description for each parameter.
    Cheers, jamie

  • Beta Tester

    This is a known bug. Use MIDI notes instead until Mark is able to get it fixed.

  • Thanks Jamie, thanks Matthew.

  • I am on a 9 hour airplane ride today. I will take a look at this. But I believe the problem occurs is because the board is not sending the data as one block, but in three byte chunks.

    Best Wishes,

  • Hello All,

    I am finding the same problem, but I had it working on a show 2 weeks ago with an older EOS.  But now with a newer Element, the same show file is not functioning.
    Any new ideas?
    Thank you

  • Dear @thesadfox,

    This issue should be fixed in the pre-release. You don't need to have a 2.0 license to get at this fix, nor do you need to re-register. You just need to download the 2.0 version and install.

    However for early adopters: if you see this, please wait for 2.0.0b3. There are several important fixes coming, and I'm building it right now. (3:18pm Berlin time, August 29)