Stage Mouse Watcher Element Placeholder

  • Hi. Although I´ve been through a lot of tutorials already, I am quite new to Isadora.

    Right now, I can tell you that all my projects will run using "Stage Mouse Watcher". The goal is to present VJ performances using touch screen systems to manipulate video clips on screen.
    Isadora´s basic tutorials already taught me how to accomplish that, but one thing is bothering me: whenever I position the mouse to move a clip, for instance, the clip "jumps" to a placeholder position (x,y coordinates) in relation to the cursor itself. This is not good.
    I wish I could place the cursor right over the video and start scrolling from that position. So, I want the cursor over the video, like centered over the video file. Is this possible?
    Imagine drawing particles. I want the particles out of the cursor itself and not pixels away from it.
    Also, is it possible to hide the cursor itself? I will use a huge touch screen and my fingers. There´s no need of a mouse cursor.
    Thanks a lot,
  • Tech Staff

    I am not sure how you are moving a clip on stage, but there is no reason that you can't find correct X,Y. It may be the difference of a center xy, as opposed to a left-top xy.. I don't know with out seeing the patch.

    as for hiding the cursor, there is a setting in the preferences under the stage tab to 'Hide cursor when in full screen'

  • Hi DusX. Thanks for the reply.

    I just added a "ctl" controller to togle on/off my stage mouse watcher to move a video in both horz and vert.

  • This is a simple example.

    Caculator is not interfering on it. It is there just to invert Y movement, because when I was moving -Y, the movie was moving +Y.
    The dancer movie clip as centered on the stage. When I positioned the cursor centered, over the video, and enabled "stage mouse watcher" by using the "ctl" modifier, the movie clip just "jump" to a +Y+X position far from the cursor, just like the image attached, while mouse/cursor position is still centered on stage. I wish to avoid that behavior.
    Thank you.


  • Okay. I no longer need "calculator", since I changed projector "hv mode" to classic.
    That also changed the placeholder position to a much better situation. Almost perfect.

    Now I notice that as far as I pull the mouse from the center of the stage, although the movie clip watches the movement, it gets more far from the cursor position itself. Anyway to avoid this?
    Thank you
  • Tech Staff

    I think this new issue is a scaling issue.
    The mouse values are probably -50->50 while the inputs for the projector is probably looking for -200 -> 200 (these may not be the exact values but the idea remains)
    click beside the projectors input and change the max min values to match the range the mouse watcher is giving you.

  • Tech Staff

    yep @DusX is right, -50 and +50 is the scaling values you have to set.
    By the way, you can also use the left mouse down and up trigger instead of pressing the ctl key. just trigger a "gate" actor on and off and let the possition values pass through the gates.


  • Thank you guys,

    I am not quite sure I know where find or to enter the proper values, so I´ve been unable to change this. What ever I did, I just made it worst.
    Any detailed help is appreciated. tks!
  • Beta Platinum

    Changing the scaling is done when you click the white text; then the MIN and MAX can be changed (in most cases).

    Scaling is one of the fundamentals of Isadora. Once you do it a few times it becomes second nature.
    Part 1:
    Part 2:


  • I got it fixed by changing projector horz pos and vert pos to Min:-50 Max:50.
    Thank you guys.

  • Another question concerning the "Stage Mouse Watcher".

    I don´t wish to use a modifier to turn/toggle watching on/off.
    I will be running my show on a touch screen environment - no iPads, OSC or Kinect. Still, I´ll be using my hands to control interactivity, directly over screen. So, I have no problems about leaving 'watching' on for all times, since I will only interact with my visual at a certain range from the screen. That´s allright.
    Still, I have this interactive issue wich I will explain using a 3D model example:
    Loaded 3D player and the Cube.3ds file provided with Isadora;
    Positioned the Cube well centered on stage;
    Loaded "Stage Mouse Watcher" and set it like that: moving X >> rotate cube X; moving Y >> rotate cube Y; Works beautifully.
    There it comes...
    But now I disable watching using a modifier or just step away from the screen (hands far from range sensors).
    Whenever I come back with my hands or use the modifier again, the object promptly resets to a certain rotation, according to the new and imediate watching coordinates. Are you following me? I don´t wish that to happen.
    So... is there a way to set certain functions on mouse watcher not to use absolute coordinates? I want them to be relative to the object itself and not absolute to the whole stage.
    Thanks a lot!!!

  • Continuing explanation.... I rotated the cube horiz 90 degress and as I move mouse away from the cube it keeps rotating.
    Now I want to bring mouse/hands back close to the cube (over it) to give it another pull to rotate it further. When I do it, it resets almost the previous rotation because of the absolute coordinates, while I wanted to keep the already rotated value and add more.

  • Tech Staff


    thats something you have to do with maths, for example with calculator actors.


  • Thanks Michel.

    Is there a way to enable/disable the "Stage Mouse Watcher" to a specific movie by selecting/pressing mouse button on it? 
    Again, thanks.
  • Tech Staff


    You can do that with comparator and gate actors. See image.
    You type the number of the movie in the "Absolute Value" actor, that passes it to the movie player and the comperator actors. So if the number maches the trigger values trigger stage one and if it doesn't match it triggers stage 6. This works if you don't have 6 stages active :-)


  • I´ll try that. Thanks a lot!