A way to automatically kill the "unexpected crash" dialog ?



  • Is there a way to ensure that the "Isadora experienced and unexpected crash" dialog does not appear - or automatically goes away after being triggered?

    Context: I have a 24/7 installation up right now that I have been able to ensure will reload after a crash - however I do not know how to keep this error from remaining up on the screen without physical intervention (someone pressing the button the clears the message.)
    Thank you for any guidance.
    -Alex


  • Are you on windows or mac? Sounds like OSX.

    For osx try this in Terminal: defaults write com.apple.CrashReporter DialogType none
    For Windows you can turn it off in the Action Center settings.
    The search bar in your browser is great for this kind of stuff ;-)


  • Mac as you guessed. Sorry to not indicate.

    Thanks.
    -A


  • I was wondering if you can stop this coming up also:

    ![](http://bytes.com/attachments/attachment/6895d1360260672/messages_quit.png)


  • The above should sort that out no? You might need to reboot or at least logout?


  • Just accidentally discovered there is an application, in Mavericks at least, called CrashReporterPrefs.

    If you put the setting on 'Server' it should avoid going into Terminal.


  • This is great! Thank you for the tip!



  • I have it set to ”Server” from the start. The message pops up some times still. BTW OS X 10.6.8



  • I think that maybe I only have the CrashReporterPrefs app because I have Xcode installed.

    As for it not always working, well thats annoying.


  • For those not on Mavericks, am attaching a screengrab of the options window you get from CrashReporterPrefs

    ec96a9-crashreporterprefs.png


Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.