assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

[SOLVED] - Capture to disk actor only working with FaceTime camera



  • I know, usually the FaceTime camera is the problem.  In this case, FaceTime camera works and several other camera inputs (PS Eye, Composite Videoglide, Blackmagic Extreme) that otherwise are behaving nicely with Isadora will not be captured and added to the media folder--whether movie input is set to add or to a specific file number, whether there are other movies in the media window or not, whether media slots are empty or .  Have reset location of capture folder, no dice.  Have tested and run into this problem with three different machines (MBA on 10.9, MBP on 10.8, and MacPro on 10.9). Isadora 2.0.0b12\. (Also tested in 1.5.3f28 and found the same behavior--got an error message when starting/stopping capture then starting again in both versions--filed a bug report from v1.)  Anyone else run into this behavior?  



  • Philifor,
    Thanks for filing the online support ticket bug report on this. We are actively working on some Capture to Disk bug fixes for the next beta release.



  • i know this is an old topic, but i have not found any solution in the forum right now and facing the same behavior

    My issue is that the capture camera to disk actor is not working with blackmagic intensity, but with FaceTime camera is working fine. The live capture setting and preview show no problems with blackmagic.

    My system is MBP 15" OSX 10.13.6 ,Izzy 2.6.1 and blackmagic  format 1080i50 (GH2)  

    Maybe there is a solution and i haven't found it, please give me a hint or workaround ....


    Diether


  • Tech Staff

    @sommerdi 

    Have you already tried the steps outlined here: https://support.troikatronix.c...?

    Best wishes,

    Woland



  • @woland

    yes .... with video in watcher actor i can process the video in from the blackmagic ....  everything looks normal .....

    Instead of the capture camera to disk .... 


  • Tech Staff

    @sommerdi said:

    yes .... with video in watcher actor i can process the video in from the blackmagic ....  everything looks normal .....

     If Capture Camera to Disk doesn't seem to work with Blackmagic but the Video In Watcher does, try this workaround using Video In Watcher and Capture Stage to Disk.


    Please let me know how it turns out.

    Best wishes,

    Woland



  • ....  Izzy crashed .... 


    video is fine on stage 6, when changing in capture stage to disk actor from one to six izzy crashed ..... in both case with stage on and off

    it look like the actor is not working with stage 6 ....


  • Tech Staff

    @sommerdi said:

    video is fine on stage 6, when changing in capture stage to disk actor from one to six izzy crashed ..... in both case with stage on and off

    Changing it to Stage 3 seems to work fine. I'll log this crash.

    Capture Camera to Disk Workaround.izz



  • yes it looks like is working ...  i need some more test, there is something strange  ...  i will give you tomorrow a detail feedback

    Thanks for your fast support

    Diether


  • Tech Staff

    @sommerdi

    I look forward to hearing from you.

    Best wishes,

    Woland



  • Thanks for the really fast feedback and your proposal for a workaround,

    but i do not agree with "solved" and is not solved ..... please change this ...

    The  "Capture camera to disk" actor is certainly not working with the Blackmagic Intensity 3.0 USB Input. In my eyes there is a major bug.

    Please correct me and give me a hint, how i can get it work, if i am wrong.

    I tested this with three different cameras and resolutions. All are working with "Capture stage to disk" actor.

    For my installation i need three stages and three camera inputs. Every additional stage is a performance penalty and right now i am not sure, if i could afford it. I am using a MBP, three projectors, two webcam and one camera with tele.

    So the workaround is a good idea, but ...  any further hint, is more than welcome ....

    Diether

     


  • Tech Staff

    @sommerdi said:

    but i do not agree with "solved" and is not solved ..... please change this ...

    With all due respect, you responded to a topic from 4 years ago, and I consider our discussion to be a separate issue from the original post.

    The Blackmagic issue is a known issue that's been solved (or will be solved shortly) in the beta for the new release of Isadora.

    If you use the link in my signature to submit a support ticket I'd be happy to assist you further with your specific issue.

    Best wishes,

    Woland



  • @woland hey just to check, is this solved for Mac and windows? Which beta specifically has the fix?


  • Tech Staff

    @fred

    It should be the most recent beta which you'll be receiving soon. I know Mark was working on Blackmagic integration recently, so if it's not solved in this most recent beta, it certainly will be soon.



  • please be patience with none expert .... i thought for a 4 year old topic must be a solution in the expert team somewhere ....

    I wasn't aware that BM is a known issue

    I was testing some more cameras and found that all with apple driver are working and i tried to run the BM with apple driver and this solved this issue.

    Maybe this helps although for other setups


    Thanks Diether



  • @woland  cool, I have the latest available current beta and it was not working. For using refresh rates and resolutions not available via apple drivers like I am using this is still not possible. I guess until the next version is in our hands the issue is not really solved but a fix is on the way. Good to know, another reason to wait for V3


  • Tech Staff

    @sommerdi said:

    I was testing some more cameras and found that all with apple driver are working and i tried to run the BM with apple driver and this solved this issue.Maybe this helps although for other setups

     Thanks! I'm sure this will be super helpful for other folks on the forum.