assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

I have an issue with projection mapping--does anyone have any suggestions?



  • I'm trying to use Isadora to coordinate a series of projection mappings. What I've been doing is projecting the photoshop interface onto some cubes and trying to map them directly in photoshop by tracing their outlines. Then I import those jpegs into FinalcutproX to edit them and make movies out of my compiled jpegs. After that, I load those movies into Isadora and project the full stage screen onto the cubes.  However, I find that Isadora changes the size of those mappings so that they no longer cover my cubes. Does anyone know of a way to adjust my settings so that they remain the same? Part of my problem is that the jpegs from photoshop also gets distorted by Finalcutpro, before being further changed when I put them in Isadora.  I know this is a super low-tech way to do mapping, but it's my only option for several reasons that are too complicated to discuss here.  My professor said something about "square vs. non-square pixels" being a possible cause, and suggested I find help here on the forums.  I'd very much appreciate if anyone has any ideas for how to make my mapping stay the same size throughout my process.  Thanks in advance, and sorry for my rambling.



  • Hi gomer_pyle,

    Typically when using photoshop to map images you want to make sure you are creating the images in the Native Resolution of the projector you are using. This will make that image pixel perfect to the output of the projector. You then need to make sure you are consistent with using the native resolution through each step. This may mean using a custom size sequence in Final Cut. It's been awhile since I've used Final Cut, but you should be able to create a custom size to match the projectors native res. Using square pixels will also be part of this.

    If your video coming from Final Cut is built to the native res when you bring it into Isadora it should go directly out to the projector without scaling.

    Good Luck!

    Cheers,

    Cam.



  • Keep everything in square pixels with anything you do in video graphics. Actually there is no need for anything else now days on my opinion. And to create media to the size of your projector native res. is good practice throughout. Even if it means redoing your clips if you change the projector. Specially for mapping.

    Then keep in mind that Isadora has a bit hard to understand scaling procedure. But if your media is consistent pixel-by-pixel then you should not need to worry about it.
    http://troikatronix.com/troikatronixforum/discussion/comment/6323#Comment_6323


  • Thanks so much, guys. This is extremely helpful info and I'm going to try what you suggested about using square pixels and making sure everything's the same resolution throughout my process.  Also, I've downloaded Premiere, and it's just a matter of my learning how to use it (got too used to FCP) Vanakaru, I think you're right about FCP being rigid.. I can't find a way to customize the resolution so I suppose Premiere is the best way to go. My thanks to both of you! You've been a great help to me.


  • Tech Staff

    I think the workflow in Premiere is nice


  • Tech Staff

    Square pixels is your friend :) 23c17d-screen-shot-2014-11-17-at-08.58.43.png



  • After Effects is even better. You can use Corner Pin to transform video to match your object shape.

    You can use AE ability to project external monitor strait to your object(unless you do outdoors/on site setrup) to create a map as well.


  • @gomer_pyle: This is not "a super low-tech way to do mapping", but one of the most accurate, if you can do it in situ. Speaking of which there is a After Effects Syphon plugin, so you can get what you see in AE right into Isadora: http://createdigitalmotion.com/2014/03/syphon-in-your-after-effects-lets-you-map-while-you-animate/

    --8


  • Wow, thanks for all of your helpful input everyone! I will check out that aftereffects plugin--sounds like just what I need.  So I was doing some more prototyping with Photoshop, making sure the resolution matched my projector's and that I was using square pixels. I didn't yet do anything with movie editing--just went straight from photoshop to Isadora so I could see if the image stayed the same.  Now when I project the full-screen stage onto my object in Isadora, it seems to be keeping the image size the same, but one odd thing that happens is that the projection suddenly moves like 6 inches above where it originally was in photoshop.  I moved my projector forward to try to match it up, but naturally that makes the image smaller.  Would there be a reason why Isadora would move the projection?



  • Does your image just shift up or it becomes larger in all. You can zoom out in Projector Actor(I assume you talking moving physical projector).



  • It actually shifts upward without me adjusting anything. Also, I had it all the way zoomed to begin with because the projection isn't big enough, otherwise. (I'm sort of projecting from a fairly short distance so it needs to be zoomed in a lot)



  • Did you try adjust position in Projector Actor? I do not know why the shift happens. Sounds like PS center does not match Isadora center. I assume your Canvas and Image size in PS is the same as in Isadora Preferences Stage size.



  • Are you editing the photoshop image full screen with the menu bars or without? Sometime if you edit with the menu bars on screen then press tab to take them out the image re-centres on the screen and moves up. Just a thought.

    I also second the AE Syphon plugin. It is very slick for this sort of thing...



  • I was mapping in Photoshop with the menu bars, and in fullscreen. Then I projected the Isadora stage in full-screen without menu bars, so maybe that is the reason for the shift. Also, when I get back home I will try moving the position in projector actor. If that doesn't work, I will most likely drop it and go with the Syphon plugin instead of PS. I guess I'm just a little daunted by learning new stuff when I have a deadline to meet, but it's worth a shot!  Thanks, all. You've been a tremendous help!!

    update: Vanakaru, it turns out there was an actor in Isadora called "zoom" which I was able to use to adjust the projection's position. :D So that's solved then! Thanks, all!!



  • Actually I was referring to Projector Actor inputs. Zoomer works on CPU only while Cl Projector and new Texture Projector can use GPU and are much better performing. a2513f-projector.png


Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.