Captured avi file don't appear in stage



  • Hello dear Isadora users,

    I have a problem : when I play a captured avi file, it doesn't appear in the stage.
    The crazy thing is that it appears OK when I put my mouse on the link between the movie player and the projector (see the still in attachment).
    I tried to play other avi files (imported ones) and it works good.
    I also tried to play the captured avi file in quicktime player and it's OK.
    Does anyone has an idea about this problem?
    Thanks!
    JM Rolland

    44786d-captured_avi.jpg



  • What version of isadora are you using?



  • Dear @jimrolland

    The reason you're not seeing the video is because it has no alpha channel. This bug should be fixed in the 2.0 version –– if you are working in 2.0 (and have purchased the 2.0 upgrade) then please let us know right away.
    But, if you're working in 1.x, then you can easily work around it this problem.
    1) Insert an "Add Alpha Channel" actor between your Movie Player and Projector.
    2) Add a "Resizable Background" actor. Set the color to white, and the resolution to match the resolution of your video.
    3) Connect the Resizable Background's output to the Add Alpha Channel's "mask" input.
    4) The video should appear.
    Please try this workaround and let us know how it works out.


  • Hello !

    I'm indeed working on V1.
    I tried what you told me Mark and it works perfectly, thanks a lot!
    Best,
    Jim Rolland


  • Hi,

    I'm playing around with this same thing and I've set it up exactly as the screengrab above only I have two capture camera to disk actors (start and stop).
    Its capturing fine and playing fine but I have to manually add the video files to the video bin.
    Any thoughts? Its probably something dead easy I have missed
    Cheers

    b0bcdd-screen-shot-2015-02-02-at-12.57.07.png



  • I have a license for V1.x but I installed V2 to have a look at it, if that helps?



  • @Bootzilla,

    Well, you most definitely should not have to add the files into the media bin manually.

    Please file a bug report at http://troikatronix.com/support/isadora -- describe your problem as completely as you can. One one of our our support team will help sort out the problem.

    Best,
    Mark



  • OK cool thanks @Mark

    Another thing I have noticed is that when I go to drag and drop files into the video bin (as you mention in the release notes) Isadora unexpectedly quits every time. I can't imagine this is the new feature you allude to. I'll mention that too in my report


  • @Bootzilla,

    @DusX, @primaldivine: please take note of this report.
    The drag and drop has been reliable for everyone on the team, on both Mac and Windows platforms. So if it's crashing, that's most definitely a bug.
    Contact technical support at http://troikatronix.com/support/isadora/ so that DusX or Primaldivine can work with you directly to look into out the problem.
    Best Wishes,
    Mark


  • Thanks @Mark 

    OK, I have solved it I think but I have now lost some functionality/actors.

    I have completely uninstalled all versions of Isadora now using App Cleaner and reinstalled v2.0.0b16 and it all seems to be working smoothly. I had installed a version (over the top of v1.3.1f06) of v2 back in October and then the latest v2 a couple of days ago when it came out. So there may have been some conflict caused by that. It seems stable now though.
    What I have lost now, is access to the Capture Camera to Disk actor and Capture Stage to Disk (and possibly others but I'm not able to check) and the media bin is no longer integrated on screen (both of these are mostly likely due to not having access to the V2 features due to having a v1 license)
    Is there any way to get a demo version of V2 now the same way that V1 had, just to have a go at the new features?
    How much is it to upgrade? I would be looking to buy about 20 licenses for education 


  • Thanks @Mark 

    OK, I have solved it I think but I have now lost some functionality/actors.

    I have completely uninstalled all versions of Isadora now using App Cleaner and reinstalled v2.0.0b16 and it all seems to be working smoothly. I had installed a version (over the top of v1.3.1f06) of v2 back in October and then the latest v2 a couple of days ago when it came out. So there may have been some conflict caused by that. It seems stable now though.
    What I have lost now, is access to the Capture Camera to Disk actor and Capture Stage to Disk (and possibly others but I'm not able to check) and the media bin is no longer integrated on screen (both of these are mostly likely due to not having access to the V2 features due to having a v1 license)
    Is there any way to get a demo version of V2 now the same way that V1 had, just to have a go at the new features?
    How much is it to upgrade? I would be looking to buy about 20 licenses for education 


  • Dear @Bootzilla,

    Well, you most certainly should have a Capture Camera to Disk and Capture Stage to Disk, even if you are running Isadora 2.0 without the 2.0 upgrade. I just checked it on my machine with an old license, and they both show up when running without the 2.0 upgrade. So something is weird if they are not there. 
    The procedure to demo 2.0 when you have an active license:
    1) Go to /Users/Shared (I'm assuming you're on Mac) and move all the files with Isadora in their name into a temporary folder. Make sure not to erase these. (Not a bad idea to compress a .zip of these files to be _really_ sure you've got a copy.)
    2) Now startup Isadora - The 2.0 features will be available since it's in demo mode. You may need to go to the Views menu and choose **Themes > Modern ** to see the new dark user interface.
    3) Play around
    4) Quit Isadora
    5) Move the registration files back to /Users/Shared from your temporary folder, replacing the one(s) that Isadora will have created when you ran it in demo mode.
    Best Wishes,
    Mark


  • Hi @Mark

    Thanks for the speedy responses to my questions, sorry to be taking up so much of your time.
    I've just double checked and I only have Capture Control and Capture to Disk when I search for "Capture" but that is with v2.0.0b16.....
    Good News: I have just updated to v2.0.1 and everything is working exactly as it should with all the actors back etc
    Thanks for the info on making it a demo version, I've just signed up the early adopter upgrade, so waiting to hear back how much it costs from that
    Many thanks again!!

Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.