3D particles - can't disable the surface

  • Hi folks - could you have a poke around with some 3d particles please and verify that they will travel all the way along the Y axis? mine always bounce, despite having a "surface position' set to zero (in the help prompt it states that when set to zero, this parameter has no effect)

    maybe i'm doing something wrong.
  • Izzy Guru

    Could you post the patch (or a simplified version) so we can recreate it exactly?


  • ok, i've stripped out the basics and attached the patch... 034efa-particular-problem.izz

  • Izzy Guru

    Having a look now and the help file does suggest that when set to 0 it should have no effect.

    I've had to turn it to -50 for it to work as expected.
    I wonder if this has anything to do with the new 3D renderer feature?

  • Try to chance Y gravity min-max to MIN and MAX instead of 50. Does it do what you want then?

  • Izzy Guru

    DBINI has it preconfigured to -10 and 10 rather than min and max. This shouldn't effect the floor position though surly?

    I will try....
  • Izzy Guru

    When changing to min and mix for the Y Gravity; all the data is positive coming from the wave generator. This makes sense really as the wave generator is all positive numbers; so it needs the scaling.

    Even with a calculator with -50 so output is -50 to 50 the 'floor' is still apparent even when suface position is set to 0\. Changing the scaling (min/max or -50/+50) its still there.... interesting.

  • i think i had a problem with it before upgrading to f25, although earlier this year - in Jamie's February workshop - it was fine.

  • Well first, the thing I said in the 'help' is totally wrong! A setting of 0 does not mean that it is disabled. I've gone and fixed that now for the next release.

    So, maybe it's clear now: the reason they are bouncing is because the 'surface pos' input is set to 0. This number is essentially the 'y' coordinate of an imaginary floor. If particles are generated at some y position higher than 0, and they are moving along negative y, they will hit the floor and bounce, responding according to the 'absorption' and 'friction' inputs.

    Sorry for the confusion; the 'help' in this case was obviously not very helpful. :-(
    Best Wishes,

  • so i fixed this by shifting the surface position to 100 and turning the absorption up to 100 to so the little particles can now wiggle all over the stage unhindered by floors or ceilings.