• I have downloaded Isadora to a new Windows 10 computer and when I try to start the program I get a message that says Quicktime needs to be installed. I installed the quicktime player 7 but iThe Apple site says it is only for Vista or windows 7. So Isadora won't open on the computer. Is there a fix for this or have I downloaded the wrong thing.


  • @DusX ? Do you have advice here?

  • To update: I uninstalled the Quick Time and Isadora to start fresh. I then downloaded Quick Time again and also installed iTunes (which I understand comes with the latest version of Quick Time) and then reinstalled Isadora on the Windows 10 machine. When I try to launch Isadora I still get the same dialogue box that says that Isadora requires Quick Time. Is Isadora not seeing Quick Time because it is looking for it in a different location? Everything is installed on the C drive.

    Another issue: I upgraded to 2.1 from 2.05 and find that the Global Keystone actors do not function properly. This is my registered version on my MacBook Pro and they worked as expected in 2.05\. I am running two projectors through Display Link external USB video adapters plugged through a Plugable USB port but don't understand why that would affect the actors in any way. I still get image, just not the global keystoning.
    Thanks, Old_Dog

  • To Update the Global Keystone issue:

    Flip Horizontal and vertical is off
    Settings: CU to ID Link = 0
    Initialize not checked = -100
    Scale Min = -100
    Scale Max = 100
    Top Left Horizontal: Pulls in Top left Horizontal & Vertical towards center
    Top Left Vertical: Pulls in Top Right Horizontal & Vertical toward center
    Top Right Horizontal: Pulls in Bottom Left Horizontal & Vertical toward center
    Top Right Vertical: Pulls in Bottom Right Horizontal & Vertical towards Center
    Bottom Left Horizontal: No Response
    Bottom Left Vertical: No Response
    Bottom Right Horizontal: No Response
    Bottom Right Vertical: No Response
    This seems like a bug but I thought to ask advice before posting a bug report.
    Also, Open Recent is crashing the program but I can open the file by using Open instead.
  • Izzy Guru


    This will be fixed in the next update.

    Best Michel

  • Tech Staff

    Yes, I reported the keystone bug recently, and have tested the fix. 

    It is working as expect for the next release.
    re: quicktime
    I am running on Windows 10 right now.. the version of Quicktime I have installed is 7.7.6
    The download page for this version, and 7.7.9 (I haven't tested this one) is: https://support.apple.com/downloads/quicktime
  • Tech Staff

    I just upgraded to 7.7.9

    Everything is working as expected.
    If you get a error dialog, please include a screen capture.

  • Dear @OLd_Dog,

    Does it help at all to install 7.7.6?
    See this thread http://www.huehd.com/faqs/windows-10-install-quicktime/
    Best Wishes,

  • Hello,

    Is there any prevision when the "Quick Time's bug" will be fixed?
    I didn't catch if it is a Apple issue or Troikatronix.
    Thank you in advance,
  • Tech Staff

    Soory. What qt bug? Generally if installed correctly it works perfectly.

  • Same problem here.  Screen shot attached.

    Installed from isadorawin-252f00-std.exe


  • @cbudin I still use quicktime 7.6 it's the only version that never gave me this sort of bug

  • Tech Staff

    I have the latest installed. However, as @Maximortal mentioned 7.6 is sometimes more stable for some users. 

    Reinstalling seems like the most likely fix.

  • I reinstalled both Isadora and Quicktime but still no joy.

    I'm hesitant to revert to an earlier version of Quicktime, as I use that a fair amount.

    Can anything be done to the Isadora code to address this issue?  What exactly is failing in Isadora to generate this error?

    Could it be file-type associations or something else in the registry?  Or a missing environment variable?  I also tried to register the QuickTime dll with:

    regsvr32 /i QuickTime.dll

    with no luck.

  • be brave! Do it! I use Isadora since 2010 and I never had a trouble related to QuickTime.

  • @Maximortal It's not Isadora I am worried about, it's QuickTime.  I use it a lot and don't want to have to regress to an earlier version.

    Frankly, if Isadora wants to be taken seriously as a useful piece of software it needs to address this issue.  I'm evaluating Isadora on the recommendation of a friend, and there's not much I can do at this point.  I can't even launch it.  Asking me to change my configuration (backwards!) on something as essential as QuickTime is a lot to ask.

  • @cbudin a few questions, how old is your Windows install? Do you have a lot of other software installed? Is this a day to day machine or one dedicated to isadora playback?

    Have you renamed, added or removed users in the windows install? Are all your driver's and Windows up to date? I don't think many other people have this problem. I have a few Windows machines and they all run great. I will go out on a limb and suggest that maybe isadora reads the registry to check if QuickTime is installed. The registry can be corrupted in a number of ways but I have seen some nightmares for changing user names or messing with group policy. 

    If your machine is a fresh windows install and you have this problem something is deeply wrong. If it is an old install on a day to day machine I would go for a reinstall of Windows.


  • @cbudin I can not figure a scenario where quicktime on a windows machine is foundamental, QT is not supported anymore on Win, even isadora is planned to became QT free, I'm really interested where you need it, may be I can suggest you an alternative or tell you if 7.6 is enough.

  • Tech Staff

    It's true that Isadora will not require QuickTime in the near future. 

    The version of quicktime installed really has nothing to do with your problem. Your problem is much more likely related to the points outlined by Fred.

    Reinstalling QT was suggested as a possible remedy since the install process may have fixed any registry issues. 

    There is no need to use an older quicktime version. For most system configurations the latest release us recommended.

    Is any error dialog presented?