V2.2 video freezes



  • I've upgraded from 2.1 to 2.2. I use a keyboard trigger actor to activate a random actor which moves the position when triggered. 
    now when I open the same file )the audio on the video file does not play and then I trigger the random actor it moves the position but there is a very small freeze on the video. Any ideas?

  • Tech Staff

    @Rathjen13

    what format is your movie? is it possible to share the patch or the part that is not behaving right?

    Best Michel



  • Quicktime HAP codec with audio



  • Dear @Rathjen13,

    I am looking into this for you. Under Windows, there was a change to the Movie Player actor that improved performance tremendously when playing movies forward at speed 1.0\. However, this may have affected the situation that I see in your patch. For the moment, stick with v2.1 and we'll get back to you in the next 24 hours.
    Best,
    Mark


  • Ok thanks for getting back quickly. I'll stick with v2.1


  • Tech Staff

    @Rathjen13

    Just tested it on a Mac and its fine here. So I guess you are on PC regarding Marks post?

    Best Michel



  • Yes, I'm on a PC (Windows 10)



  • Dear @Rathjen13,

    I can see the problem under Windows. Could you convert one movie to Apple Pro Res 422 and try it again? It seems to be HAP related. When I'm playing Apple Pro Res, there isn't any issue. But if the 'position' input jumps backwards (i.e., from 90 to 10) the HAP movie will stop outputting... often for quite some time.)

    (If you've got lots of movies in your real file, then don't make bother converting them all. But if you have the time to convert one, and to verify that it is HAP related, that would be super helpful.)

    Thanks for helping out if you can.

    Best,
    Mark



  • Also, @michel: did you try this with a HAP movie? Because I did see it on Mac OS when playing HAP.

    Best,
    Mark



  • @Mark I don't think I can encode Apple Pro Res on a PC?



  • Dear @Rathjen13,

    Well, I can actually see the same problem with a 1920x1080 HAP Movie (that's what I'm testing with) in v2.1. So it does not seem to be limited to v2.2. It could be that yours performs better because the resolution is lower. I'm making a 1440x1080 version of the HAP movie now. But even if you compressed it as Photo JPEG (Quality = 75%) and found that it worked, that would be helpful information.

    Best,
    Mark


  • Ok


  • Tech Staff

    @mark

    yes I have tried it with a 4k Hap movie. Doing the test a few times more just now I occasionally get a freezed frame that stays for about 5 seconds before it jumps to the new position even though the green position indicator at the bottom does move.

    Best Michel



  • OK, I've tried using a Quicktime (Photo JPEG 75%) in v2.2 and yes it is much better than using HAP but there is still the occasional stutter/freeze. But when comparing both versions is also much more reliable in v2.1 like HAP is.

    I also tried HAPQ and that was the same as HAP. Very smooth playback in v2.1 but not good in v2.2.


  • Dear @Rathjen13

    We are actively working on this and will announce a "hotfix" by tomorrow at the latest. (Solves some other issues too.)

    But when you say "Very smooth playback in v2.1 but not good in v2.2." are you saying very smooth response when jumping or are you simply talking about smooth playback when playing HAP? We have not seen any jitter or other playback problems with HAP under Windows or Mac OS. Please clarify.

    Best Wishes,
    Mark



  • ok



  • Dear @Rathjen13,

    See my PM to you here on the forum if you want to try the update.
    Best,
    Mark

Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.