[SOLVED] Video Preview Icon doesn't display correctly



  • Hi All!

    Does anyone can tell me whats wrong with this file(https://yadi.sk/i/A7fEcZEtrCuAB).
    On screenshot you can see that preview icon shows as White frame. 
    I have a lot files in AIC format(mov container), that i encode into Mov Mjpeg by ffmpeg.
    To convert aic files I used this command line
    ffmpeg.exe -i %1 -f qtrle -vcodec mjpeg  -pix_fmt yuv420p -f mov -b:v %bitrate% mjpeg_%1
    Source AIC files couldn't open by Isadora(I can add to Bin, but they doesn't show anything).
    What's wrong?

    7d7a9e-.png


  • Tech Staff

    It might just be the poster frame. You can change it - but not sure how on windows.



  • Doesy anyone tell me what exactly wrong with this file. I'm trying to find how to set poster frame, as Skulpture suggest, but i can't find any info about setting poster frame in MOV-files.

    By the way, Explorer icons and other Video programs displays Preview icons properly for these videos. Only Isadora displays it as white frame.
    It is very uncomfortalbe to use white frame. Please help!!!!


  • Dear @Mikhail,

    Can you make a tiny movie that you can post here so we can test it, e..g, something < 2mb?
    Best Wishes,
    Mark


  • I can't upload even 1Mb file here!

    Here same file on yandex disk https://yadi.sk/i/5P-aMhkJrF4w9

    edcb56-.png



  • Hello, mark .

    Can you tell me, did you download sample file, that I send? 
    What's wrong with this file and why Isadora doesn't display icon correctly?

    Thanks in advance.


  • Tech Staff

    @mark @mikhail

    I can confirm that loading the example file, a white thumbnail is shown in the Isadora media bin.
    Also, looking at the file in QT movie inspector, it is listed as: Photo - Jpeg, 720*576, millions of colors, 25 fps 

  • Tech Staff

    @Mikhail

    It's not the file size you cannot upload it's the file type ( there is a upload size limit, but 2mb should not be a problem). If you .zip your files they will be accepted.

    Best Michel



  • Dear All,

    I've reproduced and fixed this bug. The codec is listed with a really strange name in QuickTime Player 7:  Lavc57.20.100 mjpeg -- I have no idea what that is. Anyway, it seems that some movie codecs don't like to draw their poster frame unless the poster frame is the same size as the movie itself. (I was drawing into a much tiny thumbnail sized bitmap, the same size used in the preview window.)
    Anyway, it's fixed for the next version. @DusX please file a bug report and mark this bug as fixed.
    Thanks to @Mikhail for discovering this bug.
    Best Wishes,
    Mark


  • Very Thanks, mark!


  • Tech Staff

    Good to know. I had a feeling it was the codec when talking to the Tech Team. Strange how certain codecs behave in different ways. :)


Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.