assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

GPU actors change to CPU



  • Hi again forum. I'm trying to run my show through the GPU. But for some reason the video stream keeps changing to CPU. Are there any typical trouble shooting I should do to rectify this problem?

     thanks,
     J


  • I should add that I'm trying to update an old show to Isadora 2. 

    For example in a patch I have a '_movie player' _to '_hsl adjust' _to '_colorizer'_ to '_crop'_ to '_projector_.' I have updated all the red coloured actors and left the normal coloured ones. I still get CPU instead of GPU. BUT if I bring in all the actors I mentioned, connect them together it says GPU. I really don't want to update all the actors as it's a really complex patch. Thoughts?

  • Tech Staff

    Hm, I know it only that way that you have to update it manually.


  • Tech Staff

    I think this is due to the IO being mutated (the GPU actors also support CPU)

    So, to force GPU, add the actor you want, connect it to another GPU actor (ensure the input is still gpu... maybe add a new Projector).
    Once connected it will not be mutable anymore (mutable IO are shown as green).
    You can then connect it to the actor you planned on connecting it to (assuming it is GPU).
    If the connection works you can remove the placeholder actor (eg: Projector), if the connection doesn't work, it means the connection types don't match (you are connecting a GPU to CPU)


  • Thanks for the replies. Appreciate it. I'll try that tactic and see if it works!


Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.