Spout 2.006



  • recently I've udpated spout from 2.005 to 2.006.

    before upgrade this simple patch was working pretty well, now it crash continously if I use common setup for spout. The only combination that works is as in attached image. can some one else do some tests? 

    (I've installled spout as usual but 2.006 ahve ddl and apps in a quite different location from 2.005)

    spout.izz

    DX settings.JPG


  • Tech Staff

    just realized I am still using 2.005

    Will have to do an upgrade and report back.


  • Tech Staff

    I updated yesterday.. and had to revert because I found the ffgl plugins arent recognized as the same..  so all instances need to be replaced and relinked.

    If you are using spout in a big project. Don't upgrade.


  • Tech Staff

    @Maximortal

    Have you been able to get spout 2.006 working?


  • Tech Staff

    please see my most recent post here: https://community.troikatronix...



  • @DusX i drop into ffgl folder the DDLs you give us but I still encounter same bug

    probably i revert to 2.005


  • Tech Staff

    Do you have a laptop?
    If so you may need to define in the video cards control panel that Isadora.exe and the spout source/destination both use only the dedicated video card.
    With an nVidia card this would bypass the Optimus feature (shares between the onboard Intel video and the nVidia dedicated card), AMD has something similar.

    Its generally listed under 3D settings in the video cards control panel. Maybe on a Programs Tab.

    I recently shipped a project on 2 laptops. both with nVidia cards and Optimus, running Isadora using spout 2.06 and the new plugins I posted. They are running perfectly.
    But I had to setup both Isadora and an Openframeworks app to use only the dedicated video card in control panel.

    If thats not the issue, perhaps the supporting C++ redistributables didn't install along with Spout 2.06, it should have found that they were missing during the install and prompted an install of the package.
    If not, that could be the issue. I believe its the VS2012 runtime.



  • as you can see in image dx11 mode works fine without Isadora, booth are set as high performances. now I try to do some tests with Arena ni mate and so on. I report you later



  • here the report

    SenderReciverStatus
    Isa
    Isa
    Spout
    Ni mate
    Ni mate
    Ni mate
    Arena
    Arena
    -Isa
    -Spout
    -Spout
    -Spout
    -Isa
    -Arena
    -Spout
    -Isa
    no
    no
    yes
    yes
    no
    yes
    yes
    no

Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.